selecting a child under the "most visited" query (or the "History" query) in the places organizer shows a disabled details pane to the last selected bookmark

VERIFIED DUPLICATE of bug 407541

Status

()

VERIFIED DUPLICATE of bug 407541
11 years ago
9 years ago

People

(Reporter: moco, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

selecting a child under the "most visited" query (or the "History" query) in the places organizer shows a disabled details pane to the last selected bookmark

I'll attach a screen shot.

Comment 2

11 years ago
most visited and history folders are not QUERY_TYPE_BOOKMARKS, but are history queries, so they are selecting
 "SELECT h.id, h.url, h.title, h.rev_host, h.visit_count, MAX(visit_date), "
        "f.url, null, null "
rowToResult assigns (*aResult)->mItemId = aRow->AsInt64(kGetInfoIndex_ItemId); 
with
kGetInfoIndex_ItemId = 8 that is null for history queries while is b.id for bookmarks.
so itemId = -1

what should do the details panel for history items? don't show anything (collapse the details pane)? show read only infos? show disabled empty fields? show places values (title and url) and let the user edit them?

Comment 3

11 years ago
imho itemId should change to placeId, or an additional placeId property should be added to all nodes. while itemId is only valid for bookmarks, placeId is valid for every object.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407541
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: PC → All
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.