[1.8 branch] js-1.7.0.tar.gz does not build on WIN32

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Robin Ehrlich, Assigned: bc)

Tracking

({fixed1.8.1.18})

1.8 Branch
x86
Windows XP
fixed1.8.1.18
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 1.7

I get the following link errors when I just untar and run

nmake -f js.mak

   Creating library .\Debug/js32.lib and object .\Debug/js32.exp
jsapi.obj : error LNK2001: unresolved external symbol _js_GeneratorClass
jsapi.obj : error LNK2001: unresolved external symbol _js_IteratorClass
jsapi.obj : error LNK2001: unresolved external symbol _js_StopIterationClass
jsapi.obj : error LNK2001: unresolved external symbol _js_InitIteratorClasses
jsobj.obj : error LNK2001: unresolved external symbol _js_InitIteratorClasses
jsgc.obj : error LNK2001: unresolved external symbol _js_CloseGeneratorObject
jsgc.obj : error LNK2001: unresolved external symbol _js_CloseIteratorState
jsinterp.obj : error LNK2001: unresolved external symbol _js_NewGenerator
jsinterp.obj : error LNK2001: unresolved external symbol _js_CloseNativeIterator

jsinterp.obj : error LNK2001: unresolved external symbol _js_CallIteratorNext
jsinterp.obj : error LNK2001: unresolved external symbol _js_ValueToIterator

It seems jsiter.obj is not included.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Updated

10 years ago
Blocks: 401087
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 313059
(Assignee)

Comment 2

9 years ago
Robin, sorry for the dupe. Reopening for 1.7.1 release off of the 1.8.1 branch.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: js-1.7.0.tar.gz does not build on WIN32 → [1.8 branch] js-1.7.0.tar.gz does not build on WIN32
Version: unspecified → 1.8 Branch
(Assignee)

Comment 3

9 years ago
Created attachment 339977 [details] [diff] [review]
patch

patch to add jsiter to js.mak.

builds with vc6 and vc8 for js and jsshell. vc8 warns on a bunch of different stuff, but this should be good enough.
Assignee: general → bclary
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #339977 - Flags: review?(timeless)

Comment 4

9 years ago
Comment on attachment 339977 [details] [diff] [review]
patch

oops. i have this patch in a tree somewhere on my laptop :)
Attachment #339977 - Flags: review?(timeless) → review+
(Assignee)

Updated

9 years ago
Flags: in-testsuite-
Flags: in-litmus-
(Assignee)

Updated

9 years ago
Attachment #339977 - Flags: approval1.8.1.18?
(Assignee)

Comment 5

9 years ago
Comment on attachment 339977 [details] [diff] [review]
patch

risk: not part of the build
reason: necessary for spidermonkey 1.7 source release.
Comment on attachment 339977 [details] [diff] [review]
patch

Approved for 1.8.1.18, a=dveditz for release-drivers
Attachment #339977 - Flags: approval1.8.1.18? → approval1.8.1.18+
(Assignee)

Comment 7

9 years ago
/cvsroot/mozilla/js/src/js.mak,v  <--  js.mak
new revision: 3.9.8.2; previous revision: 3.9.8.1
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Keywords: fixed1.8.1.18
Resolution: --- → FIXED
(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR
> 1.1.4322; .NET CLR 2.0.50727)
> Build Identifier: 1.7
> 
> I get the following link errors when I just untar and run
> 
> nmake -f js.mak
> 
>    Creating library .\Debug/js32.lib and object .\Debug/js32.exp
> jsapi.obj : error LNK2001: unresolved external symbol _js_GeneratorClass
> jsapi.obj : error LNK2001: unresolved external symbol _js_IteratorClass
> jsapi.obj : error LNK2001: unresolved external symbol _js_StopIterationClass
> jsapi.obj : error LNK2001: unresolved external symbol _js_InitIteratorClasses
> jsobj.obj : error LNK2001: unresolved external symbol _js_InitIteratorClasses
> jsgc.obj : error LNK2001: unresolved external symbol _js_CloseGeneratorObject
> jsgc.obj : error LNK2001: unresolved external symbol _js_CloseIteratorState
> jsinterp.obj : error LNK2001: unresolved external symbol _js_NewGenerator
> jsinterp.obj : error LNK2001: unresolved external symbol
> _js_CloseNativeIterator
> 
> jsinterp.obj : error LNK2001: unresolved external symbol _js_CallIteratorNext
> jsinterp.obj : error LNK2001: unresolved external symbol _js_ValueToIterator
> 
> It seems jsiter.obj is not included.

Robin, can you confirm that it builds now with no issues?
You need to log in before you can comment on or make changes to this bug.