Flash movies (object tags) have higher priority than layers

RESOLVED DUPLICATE of bug 137189

Status

()

defect
RESOLVED DUPLICATE of bug 137189
12 years ago
12 years ago

People

(Reporter: borysmarcelo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 (CK-IBM) Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 (CK-IBM) Firefox/2.0.0.9

I saw the source code from that site and looks like Firefox gives higher priority to <object> tags than div and layers. This is not a good idea as most sites uses div based menus and a flash right behind it. But as flash movies has higher priority than div's, the menu always shows behind it. Could you please take a look at this. Many thanks.

other sites with the same problem:
http://www.speedy.com.br/

http://www.claro.com.br/portal/home.do?method=showHome&idlocal=58

or http://www.claro.com.br and choose option Sao Paulo DDD 11 in the drop down list

http://www.caixa.gov.br


* If W3 standard is to give object tags, generally flash movies, higher priority than div's, so my suggestion here is to accommodate both rules in Firefox. Thanks in advance. 

Reproducible: Always

Steps to Reproduce:
1. one just need enter in the site listed in this bug
2.
3.
Actual Results:  
If you enter in the sites I noted in this bug you will be able to see that Flash movies have higher priority than div menus and layers.

Expected Results:  
leave Flash Movies behind layers being shown.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137189
Reporter

Comment 2

12 years ago
This is nothing to do with X. Please reopen this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Please read bug 137189 before you reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137189
You need to log in before you can comment on or make changes to this bug.