Closed Bug 407933 Opened 12 years ago Closed 12 years ago

[Task List] Initial width of the Done column too small - checkbox image is cropped

Categories

(Calendar :: Tasks, defect, minor)

Mozilla 1.8 Branch
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: thetux.moz)

References

Details

Attachments

(2 files, 2 obsolete files)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12pre) Gecko/2007121105 Calendar/0.8pre

[Task List] Initial width of the Done column too small - checkbox image is cropped

Steps to Reproduce:
1. Start Sunbird with clean profile
2. Create a task in the default calendar
3. Check the task list layout

Actual Results:
The right border of the checkbox image in the Done column is cropped, see screenshot.

Expected Results:
The checkbox image is fully visible. Increasing the width by one or two pixels make the full checkbox image visible. I think it also would make sense to apply a fixed width to this column instead of having a sizable column.
Duplicate of this bug: 413662
@Stefan: Thanks for finding my dup... Maybe you can set this one to CONFIRMED?

@Philipp: I tried setting ' fixed="18" ' instead of ' width="18" ' without any effect...
' fixed="true" width="18" ' worked, but it resets the width for the first column, when I set it to both 'complete' and 'priority'.
I can confirm the bug.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008012320) Thunderbird/2.0.0.9 ID:2007103104
Assignee: nobody → thetux.moz
If ui-review is needed, a screenshot is in the second attachment.
Attachment #306856 - Flags: review?(philipp)
Attached image Screenshot of the applied patch (obsolete) —
Checkbox image and priority image get protected from cropping. As requested the two columns get a fixed width, too.
Attachment #306856 - Attachment is obsolete: true
Attachment #306857 - Attachment is obsolete: true
Attachment #306881 - Flags: ui-review?(christian.jansen)
Attachment #306881 - Flags: review?
Attachment #306856 - Flags: review?(philipp)
Comment on attachment 306882 [details]
New screenshot for UI-Review

looks good. thanks for the patch. R=christian
Attachment #306882 - Flags: ui-review+
Comment on attachment 306881 [details] [diff] [review]
Patch fixes cropped images and makes also the columns width fixed as requested

>+					    fixed="true"
>+					    fixed="true"
I will fix tabs before checkin here.

r=philipp, If possible I would like to have this tested on mac if possible, but since the change is minimal and expands rather than shrinks, I think it should do well.
Attachment #306881 - Flags: review? → review+
Status: NEW → ASSIGNED
Flags: wanted-calendar0.8+
OS: Windows 2000 → All
Hardware: PC → All
Attachment #306881 - Flags: ui-review?(christian.jansen) → ui-review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Checked in lightning build 2008030318 and sunbird 20080303 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.