google maps street view does display street images

VERIFIED FIXED in mozilla1.9beta4

Status

()

defect
P1
normal
VERIFIED FIXED
12 years ago
11 months ago

People

(Reporter: blizzard, Unassigned)

Tracking

({regression})

Trunk
mozilla1.9beta4
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Using a build here very close to FF3 Beta 2.  When looking at the street view listed in the URL I get flashing blocks and eventually a white empty block instead of the view on OSX.
Is it consistently reproducible?
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Reporter

Comment 2

12 years ago
Oh, yes.  Happens every time on my trunk build for today.
Reporter

Comment 3

12 years ago
Looks specific to the mac.  Tried it on the mac and it's jumpy (as plugins often are) but it works.

Using 10.5 here with Shockwave Flash 9.0 r115.
Reporter

Comment 4

12 years ago
Err, sorry, I meant I tried it on Linux (Fedora 8) and it worked.  Doesn't work on the mac.

Comment 5

12 years ago
I can confirm the same behavior.
FF3 Beta 2 on OS X Tiger.
Reporter

Comment 6

11 years ago
If you mouse over it sometimes parts of it render properly but go away.  Looks like a plugin problem - it's flash.
Reporter

Comment 7

11 years ago
Nominating to block 1.9.  Pretty visible and serious problem on the mac.
Flags: blocking1.9?
This is tied up with the CoreGraphics plugin rendering model problems documented in bug #395983.  I've confirmed that disabling CG rendering (by reporting false to a query for NPNVsupportsCoreGraphicsBool) causes street view to work correctly.
Depends on: 395983

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Target Milestone: --- → mozilla1.9beta4
Keywords: relnote
(moving relnote to the original bug - should this be duped?)
Keywords: relnote
This is the symptom that most people will run across.  People searching are more likely to find this.
Marking fixed in a mac build on 2008-02-20.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022904 Minefield/3.0b4pre.
Status: RESOLVED → VERIFIED

Comment 13

11 months ago
Google street view has worked with Firefox up to latest version 64 bit 60.02
It works with 3 other browsers OK. It just produces a blank Google street view page and does not allow any input. It maybe because of the latest Windows updates not working with Firef0x
You need to log in before you can comment on or make changes to this bug.