VERIFIED FIXED in mozilla1.9beta3

Status

()

Core
JavaScript Engine
P1
normal
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: brendan)

Tracking

({regression})

Trunk
mozilla1.9beta3
regression
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

On http://www.sanitair-online.nl/ I see only the contents of one frame, the rest is missing.

In the error console I see:

Error: redeclaration of const Iterator
Source File: http://www.sanitair-online.nl/contents/core.html?lmd=39427.558333
Line: 1218

Regression window is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1196737140&maxdate=1196738159 which points to bug 376957.
(Assignee)

Updated

11 years ago
Assignee: general → brendan
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.9 M11
(Assignee)

Comment 1

11 years ago
Iterator is not a type name in ES4/JS2, so is going away (see the proposal at

http://wiki.ecmascript.org/doku.php?id=proposals:iterators_and_generators

for details). It should not have been made immutable.

/be
Status: NEW → ASSIGNED
Flags: blocking1.9+
(Assignee)

Comment 2

11 years ago
Created attachment 292656 [details] [diff] [review]
fix

Sorry, should have seen this earlier. Will ask for jwalden to r+ if he is able just to get faster joy.

Any chance of M10? Just say no, I won't mind. Thought I'd ask. Zero-risk fix, unknown how many other sites use Iterator as a global variable.

/be
Attachment #292656 - Flags: review?(igor)
Attachment #292656 - Flags: approvalM10?
(Assignee)

Updated

11 years ago
Attachment #292656 - Flags: review?(jwalden+bmo)
Attachment #292656 - Flags: approval1.9+

Updated

11 years ago
Attachment #292656 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 3

11 years ago
Fixed:

js/src/jsiter.c 3.79

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

11 years ago
Verified fixed 
Status: RESOLVED → VERIFIED
Duplicate of this bug: 407987

Comment 6

11 years ago
Checking in js1_5/Regress/regress-407957.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-407957.js,v  <--  regress-407957.js
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/js/tests/js1_7/regress/regress-407957.js,v
done
Checking in js1_7/regress/regress-407957.js;
/cvsroot/mozilla/js/tests/js1_7/regress/regress-407957.js,v  <--  regress-407957.js
initial revision: 1.1
done
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus-

Updated

10 years ago
Attachment #292656 - Flags: review?(igor)
You need to log in before you can comment on or make changes to this bug.