Closed Bug 408288 Opened 14 years ago Closed 14 years ago

This particular animated gif looks distorted at the right side

Categories

(Core :: ImageLib, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta3

People

(Reporter: martijn.martijn, Assigned: alfredkayser)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

See the image, it looks distorted when the animation is at the right side.
This regressed between 2007-11-17 and 2007-11-18:
Regression from bug 403363.
Patch coming up. 
When the frame is clipped the source pixels are not copied in the right way to the destination frame.
Status: NEW → ASSIGNED
Assignee: nobody → alfredkayser
Status: ASSIGNED → NEW
The patch from the other bug did ensure that the image didn't crash on clipped frames, but those frames were not drawn correctly.
Attachment #293100 - Flags: review?(pavlov)
Note with this patch the second corrupted image of bug 403363 now looks much better also: https://bugzilla.mozilla.org/attachment.cgi?id=288296
Status: NEW → ASSIGNED
Flags: blocking1.9?
We should probably take this patch w/ Stuart's review.  +'ing with P2.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Attachment #293100 - Flags: review?(pavlov) → review+
Attachment #293100 - Flags: superreview?(tor)
Comment on attachment 293100 [details] [diff] [review]
V1: Really do the clipping in the right way

stuart's review should be enough here, especially since he's the module owner.
Attachment #293100 - Flags: superreview?(tor)
Comment on attachment 293100 [details] [diff] [review]
V1: Really do the clipping in the right way

stuart's review should be enough here, especially since he's the module owner.
Keywords: checkin-needed
Checking in modules/libpr0n/src/imgContainer.cpp;
/cvsroot/mozilla/modules/libpr0n/src/imgContainer.cpp,v  <--  imgContainer.cpp
new revision: 1.63; previous revision: 1.62
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
It is difficult to see, as the animation is quite quick, but there is no more distortion in the current build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Status: RESOLVED → VERIFIED
(In reply to comment #8)
> It is difficult to see, as the animation is quite quick, but there is no more
> distortion in the current build:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127
> Firefox/2.0.0.11

Firefox 2.0.0.11? I don't think it has this problem or patch! :)
Oops, copied the wrong build id:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007122105 Minefield/3.0b3pre
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.