Can't see events of other peoples in the window for inviting for an event

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: dan, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.7

We have a webDAV Server in our network and serveral calendars on the same URL. If the owner of each calendar release the calendar for the public I can see the calendar in Lighting 0.7. Thats great!!! But, if I invite one of the people to a new event I cant see the events of them in the window 'Invite User' (or similar in German 'Teilnehmer einladen'). For sure I see the events in the calendar view (the information is there), but not the mentioned window.

I suppose Lighting can't refer to the data, because there is no reference between the calendar and the email address I use in the window 'Invite User'.

If you add a field called 'owners email adsress:' to the calendar properties, Lightning have such a reference and can display the information in the window.
Otherwise the view in that window makes no sense for remote calendars.

Kind regards, 
Christian.

By the way, is there a road map for Lighting?

Reproducible: Always

Steps to Reproduce:
1. Use a webDAV server and create some accounts and calendars
2. Open the calendars with Lightning
3. Try to invite different people (from the different webDAV acounts)
Actual Results:  
Missing information in the time schedule bar in the window 'Invite peoples' (in German 'Teilnehmer einladen') for webDAV acounts

Expected Results:  
The information is in Lightning, but the information is not displayed in the mentioned window (because of the missing reference e-mail address in the calendar properties).
There is no easy way to conclude the freebusy calendar from the users email. There are some proposals on server side scheduling on a per-domain basis, that allows you to provide caldav freebusy feeds via TXT entries, but that doesn't have to do with webdav and surely won't work for freemail services.

If you have ideas how to retrieve the correct freebusy feed based on email, feel free to reopen this bug, but for now this bug is WONTFIX (probably rather CANTFIX).

Note that specific solutions, i.e a certain server allows freebusy information to be retrieved using a certain url, i.e http://myserver/freebusy.php?user=<email>, this would rather be a task for an extension. If you are intereted in creating this extension, please file separate bugs in case you come over hurdles that don't allow that to happen.

If I misunderstood you, feel free to reopen again. Note I also speak german if you'd like to contact me by email.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.