mobilelife.co.th - Website content not shown - strict comment parsing and "x-pointplus" is not "text/css" error

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
English Other
RESOLVED INCOMPLETE
11 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Details

(URL)

Seen while testing Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2. Reported via hendrix.

STR:
1. Visit website listed in URL
2. Observe that login boxes are not shown.
3. Receive error in the error console:

Error in console: Error: The stylesheet http://www.mobilelife.co.th/mobilelife/th/images/ml.css was not loaded because its MIME type, "application/x-pointplus", is not "text/css".
Source File: http://www.mobilelife.co.th/mobilelife/th/serviceinfo.jsp10?page=login
Line: 0

The site loads fine in Safari.

Comment 1

11 years ago
See bug 156145 - the text/css MIME type is required in standards mode !

A workaround (aide from setting the correct MIME-type) is to remove the DOCTYPE line, to force quirks mode.

Comment 2

11 years ago
The style MIME type is only one problem with this page (which prevents
that particular stylesheet from being used - the content should still
appear (unstyled) though).  But the DOCTYPE also triggers strict comment
parsing and there are plenty of comments with an odd number of '--'
(see bug 255357 comment 3 and 4).

Not a Firefox bug - over to Tech. Evangelism
Assignee: nobody → english-other
Component: Layout → English Other
OS: Mac OS X → All
Product: Core → Tech Evangelism
QA Contact: layout → english-other
Hardware: PC → All
Summary: Website content not shown - "x-pointplus" is not "text/css" error → mobilelife.co.th - Website content not shown - strict comment parsing and "x-pointplus" is not "text/css" error
Version: Trunk → unspecified

Comment 3

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 4

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.