Crash soon after loading www.mameworld.net/samples/ RtlpCoalesceFreeBlocks

RESOLVED DUPLICATE of bug 408310

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 408310
10 years ago
10 years ago

People

(Reporter: Yani (fr), Unassigned)

Tracking

({crash, testcase})

Trunk
x86
All
crash, testcase
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2007121415 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2007121415 Minefield/3.0b3pre

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2007121415 Minefield/3.0b3pre ID:2007121415

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007121416 Minefield/3.0b3pre 

Right after I load the page at www.mameworld.net/samples/ , I got a crash.
Sometimes,it takes a few second to actually get the crash.

Reproducible: Always

Steps to Reproduce:
1. load the site
2. wait a short amont of time

Actual Results:  
firefox crashes

Expected Results:  
no crash

http://crash-stats.mozilla.com/report/index/fa933fca-aaac-11dc-a553-001a4bd43ed6
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Keywords: crash

Updated

10 years ago

Comment 1

10 years ago
Crashes my Mac trunk debug build too.  The crash seems to be during cycle collection.

Comment 2

10 years ago
Created attachment 293241 [details]
Jesse's stack trace

Comment 3

10 years ago
Actually, looks like http://www.mameworld.net/samples/TOCFrame.htm is triggering random memory corruption.  It frequently causes an immediate crash, but can lead to a crash anywhere.

Comment 4

10 years ago
http://www.mameworld.net/samples/pics/galaga88.gif is what triggers the crash.  Shift+reloading it a few times usually crashes Firefox.
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib

Updated

10 years ago
Flags: blocking1.9?
Keywords: testcase

Comment 5

10 years ago
Created attachment 293242 [details]
galaga88.gif (triggers random memory corruption)
Attachment #293241 - Attachment is obsolete: true

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

10 years ago
# 20071212_0908 crash
# 20071212_0851 no crash

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2007121209 Minefield/3.0b3pre ID:2007121209 --> crash

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2007121209 Minefield/3.0b3pre ID:2007121209 --> no crash

http://hourly-archive.localgho.st/win32/20071212_0908_checkins.html
related to Bug 403578  ?
(Reporter)

Comment 7

10 years ago
(In reply to comment #5)
> Created an attachment (id=293242) [details]
> galaga88.gif (triggers random memory corruption)
> 

thanks for narrowing it this :)
so it is probably Bug 403578

Comment 8

10 years ago
Created attachment 293243 [details]
valgrind log

Comment 9

10 years ago
CCing Alfred Kayser, who fixed bug 403578.

Comment 10

10 years ago
Actually this is a DUP of bug 408310.
With the patch that I submitted there, mozilla (seamonkey/firefox) doesn't crash on this image anymore.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408310
You need to log in before you can comment on or make changes to this bug.