Last Comment Bug 408445 - Blocklist (blacklist) "Free Download Manager" ("FDM") extension on trunk
: Blocklist (blacklist) "Free Download Manager" ("FDM") extension on trunk
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: P1 major (vote)
: 3.2
Assigned To: Michael Morgan [:morgamic]
:
Mentors:
http://www.freedownloadmanager.org/do...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 18:02 PST by -fullmetaljacket-
Modified: 2016-03-07 15:30 PST (History)
35 users (show)
mbeltzner: blocking‑firefox3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
blocklist.xml snippet (310 bytes, text/xml)
2008-01-16 21:22 PST, Arie Paap [:wildmyron]
no flags Details
updates snippet to include 1.3.1 maxVer (307 bytes, text/xml)
2008-03-06 15:53 PST, Alex Polvi
no flags Details
Adds FDM to blocklist.html (632 bytes, patch)
2008-03-06 16:00 PST, Alex Polvi
no flags Details | Diff | Splinter Review
new blocklist xml for firefox after we add FDM (758 bytes, text/xml)
2008-03-12 03:32 PDT, Michael Morgan [:morgamic]
no flags Details
Screenshot showing FDM blocklisted (157.10 KB, image/png)
2008-03-24 15:39 PDT, Stephen Donner [:stephend]
no flags Details
Bug 382356 - Trunk topcrash on startup (deleted)
2009-05-03 11:57 PDT, Rowdy
no flags Details
Bug 408445 - Blocklist (blacklist) "Free Download Manager" ("FDM") extension on trunk (deleted)
2009-05-03 12:26 PDT, Rowdy
no flags Details

Description -fullmetaljacket- 2007-12-14 18:02:51 PST
since free download manager extension is causing firefox 3.0 to crash (see bug 354624 and dups) and it was the extension fault (bug 354624#c32), i think we should blocklist it to save end users from troubles. 

troubled extension is fdm extension ver 1.0 to 1.3 (latest).
Comment 1 Jesse Ruderman 2007-12-14 18:55:49 PST
It only needs to be blocklisted for trunk, right?
Comment 2 -fullmetaljacket- 2007-12-14 19:00:05 PST
yes, fdm extension works fine on branch.
Comment 3 Michael Morgan [:morgamic] 2007-12-14 19:25:40 PST
So 1.0-1.3, Firefox 3.0 and up?
Comment 4 -fullmetaljacket- 2007-12-14 19:32:59 PST
yup. :)


Comment 5 Justin Scott [:fligtar] 2007-12-17 21:43:41 PST
Remember we'll need to update http://www.mozilla.com/en-US/blocklist/ before it's done as well, otherwise people will be seeing a blank page when they want more details. Although if it's only on trunk, I guess it's not a huge deal.
Comment 6 -fullmetaljacket- 2008-01-16 16:26:29 PST
fwiw, version 1.3.1 of this extension no longer crashes firefox 3.0.

 
Comment 7 Arie Paap [:wildmyron] 2008-01-16 21:22:19 PST
Created attachment 297489 [details]
blocklist.xml snippet

This is the xml required to be added to the blocklist.xml file hosted on amo. It blocks ver 1.0->1.3 of the extension for Firefox 3.0a1 and up.

I don't know how to go about getting this staged/live on amo or how to get http://www.mozilla.com/en-US/blocklist/ updated.

fullmetaljacket: do you know what the corresponding version numbers for the application are? And which is the first build of FDM v2.5 which has the fix? Also I'm a bit confused about versioning of FDM because bug 354624 comment 0 says v2.9
Comment 8 Stephen Donner [:stephend] 2008-01-16 21:31:02 PST
(In reply to comment #7)
<snip

> I don't know how to go about getting this staged/live on amo or how to get
> http://www.mozilla.com/en-US/blocklist/ updated.

I'm not sure the official policy, but emailing amo-admins@mozilla.org is a good way to reach them/us (I own QA for AMO now); I'll also let them know.
Comment 9 Justin Scott [:fligtar] 2008-01-16 21:42:41 PST
I don't see the point in blocklisting this if there's a fix out and people will be automatically updated. Nothing was blocklisted for over a year after the capability was added in Firefox 2, and all of the sudden we have a flurry of these requests. I think we're going to set bad precedent and will have people requesting blocklisting for every little thing.

And blocklisting won't help at all on the (malicious) security front once everyone knows it can be done and just disables the blocklist along with their malicious extension.
Comment 10 Michael Morgan [:morgamic] 2008-01-16 21:48:04 PST
Fix deployed, there is auto-update for the extension and client, so no reason to blocklist as a formality.
Comment 11 Michael Morgan [:morgamic] 2008-01-16 21:49:08 PST
Okay, just the client since it's a plugin, but you get the idea... :)
Comment 12 -fullmetaljacket- 2008-01-17 19:17:15 PST
why we are being inconsistent? internet download manager version 2.1 to 3.3 had been blocklisted (bug 382356) even new version of that extension is already available (https://bugzilla.mozilla.org/show_bug.cgi?id=382356#c20). 
Comment 13 Michael Morgan [:morgamic] 2008-01-17 19:45:41 PST
Because they took longer and it was more prevalent.  The nature of the crash was also more severe (crash on startup, guaranteed).  At least with this, worst case, users still have a client update path and the client can update with the plugin installed.  In the other case, since startup failed, users would be stuck.

Does that answer your question?

Also, I'd ask what the net benefit of blocklisting now would be.  I think if you compare the two situations, the net benefit is very small here, and doesn't warrant blocklisting this retro-actively.  Do you disagree?
Comment 14 -fullmetaljacket- 2008-01-20 16:00:46 PST
(In reply to comment #13)
> Because they took longer and it was more prevalent.  The nature of the crash
> was also more severe (crash on startup, guaranteed).  At least with this, worst
> case, users still have a client update path and the client can update with the
> plugin installed.  In the other case, since startup failed, users would be
> stuck.

ok i agree, that justify why this bug is wontfix.

Comment 15 -fullmetaljacket- 2008-02-15 00:08:21 PST
(reopened due to bug 416521)
Comment 16 chris hofmann 2008-03-06 14:26:37 PST
 	 RtlpCoalesceFreeBlocks is the #4 ranked top crash for fx3 beta3.  we should get on with the blocking of that extension, or figure out how to update it if there is a version with all the fixes needed to make it stable.
Comment 17 Alex Polvi 2008-03-06 15:53:22 PST
Created attachment 307830 [details]
updates snippet to include 1.3.1 maxVer

Here is the updated snippet. I downloaded the latest FDM and 1.3.1 was the maxVer I was given. 

PS: I assume we've tried to contact the developer?
Comment 18 Stuart Parmenter 2008-03-06 15:59:31 PST
I sent mail via some link on their website...
Comment 19 Alex Polvi 2008-03-06 16:00:24 PST
Created attachment 307831 [details] [diff] [review]
Adds FDM to blocklist.html

Here is the HTML for blocklist.html -- only in en-US. Do we need to localize?
Comment 20 Alex Polvi 2008-03-07 10:31:26 PST
here is the sql for updating the remora db:

insert into blitems(guid,min,max) values('fdm_ffext@freedownloadmanager.org','1.0','1.3.1');
insert into blapps(blitem_id, guid, min, max) values((select id from blitems where guid = 'fdm_ffext@freedownloadmanager.org'), '{ec8030f7-c20a-464f-9b0e-13a3a9e97384}', '3.0a1', '*');

staged here: 

http://morgamic.khan-vm.mozilla.org/amo/site/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.0b1/

Could someone land/stage the www.m.c patch?
Comment 21 Ted Mielczarek [:ted.mielczarek] 2008-03-11 10:39:55 PDT
People are still crashing here, despite there being an updated version of this extension:
http://forums.mozillazine.org/viewtopic.php?t=636336
Comment 22 Alex Polvi 2008-03-11 15:15:40 PDT
I've done as much leg work as I can. Morgamic, Justin, can you help deploy?
Comment 23 Michael Morgan [:morgamic] 2008-03-11 15:17:03 PDT
Yeah, I took the bug.
Comment 24 Michael Morgan [:morgamic] 2008-03-12 03:31:46 PDT
Filed bug 422359 to add the blocklist entry, will push the site change once it's actually blocklisted.

Do we need to localize this change?  Who do we talk to?
Comment 25 Michael Morgan [:morgamic] 2008-03-12 03:32:47 PDT
Created attachment 308834 [details]
new blocklist xml for firefox after we add FDM

This is what blocklist.xml will look like after the db update...
Comment 26 Wil Clouser [:clouserw] 2008-03-12 09:49:27 PDT
(In reply to comment #24)
> Filed bug 422359 to add the blocklist entry, will push the site change once
> it's actually blocklisted.
> 
> Do we need to localize this change?  Who do we talk to?
> 

I'll add it to the list for localizers once the FF3 redesign launches.  In the meantime the locales will fallback to English.
Comment 27 Alex Polvi 2008-03-12 11:37:39 PDT
This is now blocklisted in production. 

https://addons.mozilla.org/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.0b3/

Crashes should start going away... not resolving until www.m.c is updated
Comment 28 Wil Clouser [:clouserw] 2008-03-12 14:19:33 PDT
(In reply to comment #27)
> Crashes should start going away... not resolving until www.m.c is updated
> 

Kubla is having a problem, I suspect due to fallout from bug 422500.  Waiting on output of svn status from IT.
Comment 29 -fullmetaljacket- 2008-03-12 19:41:04 PDT
i can confirm that fdm extension is now disabled on my machine due to blocklisting.

thank you to all who work on this. :D
Comment 30 Wil Clouser [:clouserw] 2008-03-12 22:56:29 PDT
> Crashes should start going away... not resolving until www.m.c is updated
> 

https://www.mozilla.com/en-US/blocklist/
Comment 31 mark trinder 2008-03-20 18:49:50 PDT
(In reply to comment #0)
> since free download manager extension is causing firefox 3.0 to crash (see bug
> 354624 and dups) and it was the extension fault (bug 354624#c32), i think we
> should blocklist it to save end users from troubles. 
> 
> troubled extension is fdm extension ver 1.0 to 1.3 (latest).
> 

why i had no problems wit fdm on beta 4 mabe it crashes other ppl cos their comp sucks
Comment 32 Tony Chung [:tchung] 2008-03-24 15:36:39 PDT
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032405 Minefield/3.0b5pre.   Tested out FDM version 1.0, and it comes up blocklisted against AMO and addons manager.

I've also verified the latest FDM v2.5 at http://www.freedownloadmanager.org/download.htm, is NOT blocklisted and works as expected.

Still cant repro the crashes though.   If anyone can reproduce it, please open a new bug unless its related to an existing one.
Comment 33 Stephen Donner [:stephend] 2008-03-24 15:39:14 PDT
Created attachment 311451 [details]
Screenshot showing FDM blocklisted

For posterity
Comment 34 sunil pon dnaiel 2008-04-01 07:42:10 PDT
FDM is working fine with mine Firefox 3 b4.

Anyway i can enable it without firefox blocklisting it.
Comment 35 Juan Luis 2008-04-06 05:59:20 PDT
FDM was working fine to me too.
How I can enable it?
Comment 36 antonak@verizon.net 2008-04-14 07:55:31 PDT
One way it to use the IE Tab extension and set the site to use IE instead of firefox.  Not perfect, but it'll work.
Comment 37 Tony Chung [:tchung] 2008-05-08 13:36:47 PDT
(In reply to comment #35)
> FDM was working fine to me too.
> How I can enable it?
> 
you can also edit the FDM section in your blocklist.xml file.   Or remove the file altogether. 
Comment 38 bem 2008-06-01 14:20:04 PDT
This is the first time I have been affected by blocklisting so I have no idea how prevalent it has been.  I do know that I find it very irritating to not have the functionality of the program I have long used without knowing why for days and days after I upgraded to 3.0.  Not until I stopped to install some add-ons did the notification show up.

In cases like this, in which the problem is not pandemic, I would suggest a warning with an option to proceed or not.  I would gladly have risked a harmless crash or two before choosing to uninstall rather than the frustration and inconvenience of the last few days of heavy downloading without understanding why I couldn't use my favored resumable downloader.
  
Comment 39 chris hofmann 2008-06-01 16:36:13 PDT
sounds like providing the rational for the reasoning behind the blocking might be good. is there a a way to do that on the blocking page or should we file a bug to figure out how to build that into the web page and the UI. 
Comment 40 timeless 2008-06-02 02:47:28 PDT
chofmann: people are getting here based on 
https://www.mozilla.com/en-US/blocklist/
(changed by attachment 307831 [details] [diff] [review])

which is normal html. it'd be trivial for us to put a more useful and scarier message into the page instead of directly linking to this bug.

we should probably include an indication of how many crashes something has caused, the penalty to MTBF, and an indication that it was in the top 10 of crashes plus a hint at the number of our customers who reported bugs (indicating just how many real people have suffered enough to complain to us).
Comment 41 Wade Stewart 2008-06-22 16:34:45 PDT
My FF3 at work accepted using FDM just fine, but my FF3 copy at home does not.  Can there be a way to at least choose to unblock so we can see for ourselves if it works or not?  
Comment 42 Wade Stewart 2008-06-23 18:58:27 PDT
Reinstalling FDM today restored functionality in FF3.  
Comment 43 Reynaldo Freesz 2008-07-09 12:27:20 PDT
I think that when Firefox3 became exaustly test with complements it should be the best browser I ever used. I´ve install DownThenAll and its wonder.
Comment 44 Michel Garcia 2008-08-14 14:41:55 PDT
Hi.
Just to know when did Mozilla and Firefox turned into a dictatorial regime where people I don't know take decisions disable something and not even let the option of enabling it at people's own risk?
Comment 45 Michael Morgan [:morgamic] 2008-08-14 14:44:54 PDT
http://www.answers.com/tact&r=67
Comment 46 Grey Hodge (jX) 2008-08-14 14:47:53 PDT
See "Benevolent Dictator"
http://www.mozilla.org/mission.html
Comment 47 Michael Morgan [:morgamic] 2008-08-14 15:02:04 PDT
So really, to answer your question, it has always been the case.  

But I'll add that we're not going to:
* make everyone happy
* be right

But:
* decisions are made with the user in mind
* we can work together to fix this

What hurts is assuming otherwise, and speaking in a way that doesn't promote collaboration.  So, as I noted in comment #45, tact is very important -- for the same reason here as it is in any other forum.

Our "policy" is described here:
https://wiki.mozilla.org/Blocklisting

Especially with plugins, this is relatively new and we're still getting a feel for the best uses of this service.

In this case, if FDM is working again, we should look at shortening the blocklist range to only crashing versions.  Do we have more info on this?
Comment 48 Michael Morgan [:morgamic] 2008-08-14 15:02:45 PDT
(In reply to comment #47)
> But I'll add that we're not going to:
> * be right
Hah.  Meant "always be right".  ;)
Comment 49 Wombat 2009-02-20 19:21:24 PST
Hi,
The status of this bug says it's been verified and fixed, however I still can't use FDM 2.5 with firefox 3.0.6 on my windows XP Pro SP3 machine.
I have deleted the FDM section in my blocklist.xml file. That didn't work.
I reinstalled FDM. That didn't work.
I renamed my blocklist.xml to blocklist.old. That didn't work.

How do I get FDM to work with firefox if this has been fixed?
Comment 50 Pete McDermott 2009-03-28 09:55:21 PDT
(In reply to comment #49)
> Hi,
> The status of this bug says it's been verified and fixed, however I still can't
> use FDM 2.5 with firefox 3.0.6 on my windows XP Pro SP3 machine.
> I have deleted the FDM section in my blocklist.xml file. That didn't work.
> I reinstalled FDM. That didn't work.
> I renamed my blocklist.xml to blocklist.old. That didn't work.
> 
> How do I get FDM to work with firefox if this has been fixed?


I had same problem - I am now using Firefox 3.0.8 uninstall plub in for FDM then upgrade latest FDM (note - I still had a problem with FDM Lite) so using full version FDM 3.0 build 848 (still free!)

link is http://www.freedownloadmanager.org/download.htm
Comment 51 Pete McDermott 2009-03-28 09:56:48 PDT
oops! plub in - should read plug in - LOL
Comment 52 Rowdy 2009-05-03 11:57:36 PDT
Created attachment 375528 [details]
 Bug 382356 -  Trunk topcrash on startup
Comment 53 Rowdy 2009-05-03 12:26:15 PDT
Created attachment 375530 [details]
 Bug 408445 -  Blocklist (blacklist) "Free Download Manager" ("FDM") extension on trunk
Comment 54 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-05-03 14:36:57 PDT
The content of attachment 375528 [details] has been deleted by
    Dave Miller [:justdave] <justdave@mozilla.com>
who provided the following reason:

Windows EXE file, unrelated to bug

The token used to delete this attachment was generated at 2009-05-03 14:36:49 PDT.
Comment 55 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-05-03 14:37:28 PDT
The content of attachment 375530 [details] has been deleted by
    Dave Miller [:justdave] <justdave@mozilla.com>
who provided the following reason:

Windows EXE file, unrelated to bug

The token used to delete this attachment was generated at 2009-05-03 14:37:21 PDT.
Comment 56 mark schoenberg 2010-07-05 07:33:52 PDT
I am using minefield/4.0b2pre Gecko/20100705 and fdm version 3.0 build 852
It is possible to configure flashgot (v 1.2.1.27) to use fdm for downloads
despite the fact that fdm is reported as disabled.  I have seen no problems
with crashes.  Before fdm was blocklisted, I used it with and without flashgot,
again without problem.
Comment 57 Arie Paap [:wildmyron] 2010-07-16 00:24:20 PDT
The current version of FDM and its Firefox extension is not blocklisted by Firefox.

The current version of the FDM extension is disabled in Minefield because it only claims to be compatible with versions 1.5 - 3.* of Firefox (and Minefield). As Minefield is at version 4.0b2pre the extension is considered incompatible.

Note You need to log in before you can comment on or make changes to this bug.