Auto updates will apply and break xulapps running on firefox using -app

RESOLVED DUPLICATE of bug 314148

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 314148
11 years ago
10 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
STR:

1. Open firefox.
2. Run an xulapp on firefox (firefox -app c:\prism\application.ini f.e.).
3. Detect an update in firefox, download and restart.

At this point the firefox instance restarts, applys the update and runs firefox.

The prism instance is now running on a changed runtime to that it started on.

I attempted this twice, the first time prism just stopped responding to input and eventually crashed, the second time it kind of worked except all js in the website appeared to fail.

When applying the automatic update we should be checking that another instance of firefox running a xulapp isn't already running and not apply the update if that is the case.
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
Oops, really the same issue as bug 314148
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 314148
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.