Print to File leaks an nsStringBuffer

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({mlk})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 293431 [details]
leak log

Build: Build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre)
Gecko/2007121517 Minefield/3.0b3pre


Steps to reproduce:
Go to http://litmus.mozilla.org
Select Print Preview
Print to File
Quite Firefox
- Leak

nsStringStats
 => mAllocCount:          52049
 => mReallocCount:         8693
 => mFreeCount:           52048  --  LEAKED 1 !!!
 => mShareCount:          59353
 => mAdoptCount:           6047
 => mAdoptFreeCount:       6047

Updated

10 years ago
Summary: Print to File leak → Print to File leaks an nsStringBuffer

Updated

10 years ago
Keywords: mlk

Comment 1

10 years ago
I don't see any trace-refcnt leaks with the equivalent action on Mac (Print > PDF > Save as PDF).
(Reporter)

Comment 2

10 years ago
i'm currently not able to reproduce this leak, maybe this was caused by something else, closing as works for me for me
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.