Fails to print solid borders when border width=1px and style=solid

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: bobbysmith007, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When trying to print a document with solid border tables in it, print preview shows the document correctly, but printing the document results in thin double borders.  If border width > 1px, then the bug does not manifest itself.

Reproducible: Always

Steps to Reproduce:
1. Open page with a single, solid border on it
2. Click print then confirm
3. Wail in anguish about funny looking border

Actual Results:  
I get a table with thin borderlines with a small space between them.

Expected Results:  
A table with a thin solid border on it after printing
(Reporter)

Comment 1

11 years ago
Created attachment 293557 [details]
A demonstration of single border print bug

If you attempt to print this file, the printed borders will not be the same as the print preview borders.

Comment 2

11 years ago
(In reply to comment #1)
> Created an attachment (id=293557) [details]
> A demonstration of single border print bug
> 
> the printed borders will not be the same as the print preview borders.

I used Print Preview with the testcase, in Landscape and Portrait mode, and sized 300% but all was well, Firefox and Seamonkey. 

Do you see Print Preview as expected, but Print failing? What printer are you using?
(Reporter)

Comment 3

11 years ago
It was only the actual printed output that was screwy (print preview looked fine).  Just tried it again in the newest firefox beta and it prints fine now.  

Thanks for the quick work :)

Hope it releases soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Version: unspecified → 2.0 Branch

Comment 4

11 years ago
Resolution is WORKSFORME, if you don't know which check-in did solve your problem, or DUPE if your bug is identical to that one in which it was fixed.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.