Cannot add bookmarks to menu, and receive error message each time I try to drag-and-drop a tab to bookmarks.

RESOLVED DUPLICATE of bug 400443

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 400443
10 years ago
8 years ago

People

(Reporter: Kevin Stevenson, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

I was trying to add a page to my bookmarks by dragging the tab to the Bookmarks folder. I received an error message, and the bookmark was not added to my Bookmarks folder.

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs.
2. Drag the tab to the Bookmarks folder in the File menu.

Actual Results:  
Once I performed the above steps, I received the following message:
ASSERT: Insertion point for an menupopup view during a drag must be -1!
Stack Trace: 
0:BMDH_onDrop([object MouseEvent],[object Object],[xpconnect wrapped (nsISupports, nsIDragService, nsIDragSession)])
1:([object MouseEvent],[object Object])
2:ondragdrop([object MouseEvent])
3:invokeDragSessionWithImage([object XULElement],[xpconnect wrapped nsISupportsArray],null,7,null,0,0,[object MouseEvent])
4:([object MouseEvent],[object XULElement])
5:ondraggesture([object MouseEvent])


Expected Results:  
The program should have added the tab to the Bookmarks folder.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121800 Minefield/3.0b3pre

I see this indeed happen when I test this with my default profile.
When I test this on a new profile with the default set of bookmarks, I see no assert but the bookmark is added to the Mozilla Firefox folder (=wrong folder) instead.
I don't know if the reported problem belongs to bug 337761 or if this is a (already reported) separate issue. Confirming for now.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 409001
the Assertion Message is Bug 400443. I will dupe this Bug to 40443 because of the ASSERT Error message the user got.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400443
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.