View source with an external editor doesn't works with a web page with a ' in title and UTF-8 encoding, editor is opened but file is not found

RESOLVED FIXED

Status

()

defect
--
minor
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: gialloporpora, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

- Operating System: Windows XP
I have set Firefox to use an external editor to view the source code:
- view_source.editor.external;true
- view_source.editor.path;

First with my default  text editor (Crimson Editor) and after with a more popular Notepad++. 

I have a problem viewing the code of my personal site (I have inserted as URL) not for spam) but I think it is more general:

- Character encoding:  UTF-8
- In the title of the page a special character: '

Character encoding is essential, when I used a ISO-8859-1 encoding the problem not happen.
I have set Firefox to use an external editor to view the source code:
- view_source.editor.external;true
- view_source.editor.path;

First with my default  text editor (Crimson Editor) and after with a more popular Notepad++. 

I have a problem viewing the code of my personal site (www.gialloporpora.netsons.org not for ) but I think it is more general:

- Character encoding:  UTF-8
- In the title of the page a special character: '

Character encoding is essential, when I used a ISO-8859-1 encoding the problem not happen

Trying to show the source code of the page (CTRL-U), it appears the external editor (it is opened) but it doesn't find the file   created by Firefox.

If I change the name of my blog removing ' character I view source in my editor without problem.

Errore with Crimson Editor like external editor:
http://img504.imageshack.us/img504/6379/edexbug1rc3.png

Errore with Notepad++ like external editor:
http://img135.imageshack.us/my.php?image=edexbug2fb1.png


Reproducible: Always

Steps to Reproduce:
- Setting an external editor to view source code of page
- opening a web page with UTF-8 encoding  which contains a ' in the title
Actual Results:  
The external editor is opened but it returns an error message, it doesn't find the file created by Firefox

Expected Results:  
The external editor open the file with the source code of the page

I think is a problem with command line argument passed by FF to the external editor. This error not appear with ISO-8859-1 encoding
FF 3.0 Beta2 have the same error
Depends on: 411511

Comment 1

11 years ago
This probably isn't a Firefox bug. Notepad++ doesn't support Unicode filenames. I think the appostrophe you were trying to use didn't belong to your current locale, that's why Notepad++ wasn't able to open the file. Use standart Notepad instead.

By the way, I didn't manage to reproduce your bug. Everything seems to work fine for me, even with Notepad++.
This is definitely a real Firefox bug. It may happen to work with file names in the Latin-1 range on en-us Windows, but not for out-of-locale names, even with a unicode-aware app. I tested with a file called Русский.html, and Notepad tried to open " CAA:89.html". In other words, the filename is going through a lossy 16-bit to 8-bit conversion, and U+0420 U+0443 U+0441 U+0441 U+043A U+0438 U+0439 becomes U+0020 U+0043 U+0041 U+0041 U+003A U+0038 U+0039.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
Now I see it. I just didn't try with other Unicode titles.

Comment 4

11 years ago
Now I see it. I just didn't try with other Unicode titles. Then the severity should be more thant "minor".
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
(Reporter)

Comment 5

10 years ago
I think that there is a little difference by created file and what Firefox pass to Editor, the problem is not the accented letter, but the apostrof (' ' ).
The editor try to open this file:
C:\DOCUME~1\ADMINI~1\IMPOST~1\Temp\Il blog che non cè.htm

The file created in temp directory have this name:
Il blog che non c'è.htm

The ' is the problem, it is missing to the argument passed by FF to editor (it could depends from some Windows conversion of ' from commandline arguments)
Right, that is similar to what I said in comment 2: the apostrophe character is U+2019, and it gets passed to the editor as 0x19.

I apologize that I totally dropped this on the floor after bug 411511 got pushed out from Firefox 3. I'll get back on it.
(Reporter)

Comment 7

10 years ago
No problem :-)
Thanks for your interest in solving this issue.
Sandro
(Reporter)

Comment 8

10 years ago
Now, I have modified something with All SEO pack and the problem is disappeared:
http://www.gialloporpora.netsons.org/

the file have still the ' in the name, I don't know the reason. 

I am not a programmer ora an expert user, but I think that a possible solution would be to generate a random name for the file. 
The file is in the %temp% directory and, I think, user are not really interested to the filename, in this way problem with strange characters disappears. 
For example, generating a file with name "milliseconds-of-local-time.html".
What do you think ?
FIXED by bug 411511. Note that in spite of comment 8, the bug still existed when the "é" was not representable in the Windows native character set.

(In reply to comment #8)
> the file have still the ' in the name, I don't know the reason. 

The ' changed from U+2019 RIGHT SINGLE QUOTATION MARK to U+0027 APOSTROPHE, which worked around the bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 576972

Comment 11

9 years ago
This bug still exists in FF 3.6.6 (tested on Ubuntu 10.04 and MS Windows XP Pro. SP3).

On Ubuntu with en_US.utf8 locale I created two empty files (using Nautilus) on an ext4 file system:
Ångström.html and čip.html
They can be opened fine by FF, OpenOffice.org, gvim editor etc.

But, if any of the files is open in FF, it is not able to view the page source (Ctrl+U or View -> Page Source) using an external editor. The external editor complains that it cannot open the file as it does not exist.

Process info about the editor program reveals that the Å, ö and č characters in the filename are not passed correctly from FF to the external editor.
For what it's worth, this bug was specifically about Windows, although I see that I did say in bug 411511 comment 8 that I tested the fix on Windows Mac and Linux. I won't have access to Windows or Linux systems for a few days, but it works on Mac with Ångström.html.
(In reply to comment #11)
> This bug still exists in FF 3.6.6 (tested on Ubuntu 10.04 and MS Windows XP

Oh, duh! The fix wasn't checked in to 3.6.6. If you care to test a nightly build or Firefox 4 beta 1, you should see that it works fine.

Comment 14

9 years ago
True, the bug doesn't exist in Firefox 4.0b2 (tested on Windows XP).
But, it is still present in Firefox 3.6.8 (tested on Ubuntu 10.04 and Windows XP).

-- rpr.

Updated

8 years ago
Duplicate of this bug: 444953
You need to log in before you can comment on or make changes to this bug.