Last Comment Bug 408935 - Can't --disable-xpcom-obsolete in a 1.8 branch static build
: Can't --disable-xpcom-obsolete in a 1.8 branch static build
Status: VERIFIED FIXED
: verified1.8.1.12
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 1.8 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Mark Mentovai
:
Mentors:
Depends on:
Blocks: 408959
  Show dependency treegraph
 
Reported: 2007-12-18 18:35 PST by Mark Mentovai
Modified: 2008-01-30 16:22 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Static builds should only link with xpcom-obsolete when it is enabled (914 bytes, patch)
2007-12-18 18:37 PST, Mark Mentovai
ted: review+
dougt: review+
dveditz: approval1.8.1.12+
Details | Diff | Splinter Review

Description Mark Mentovai 2007-12-18 18:35:43 PST
We no longer use the xpcom-obsolete module and would like to remove it from Camino 1.6, based on the 1.8 branch.

--disable-xpcom-obsolete doesn't work in 1.8 branch static builds, because mozilla/config/static-config.mk always requires libxpcom_compat (the xpcom-obsolete module) unless building minimo.

Currently, the check in static-config.mk looks like this:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/config/static-config.mk&rev=3.23.2.6&mark=130-133#130

I'd like to change this to check for MOZ_NO_XPCOM_OBSOLETE instead, as is done on the trunk:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/config/static-config.mk&rev=3.42&mark=112-115#112

ifndef MOZ_NO_XPCOM_OBSOLETE is exactly equivalent to ifdef MINIMO for all known builds.  MOZ_NO_XPCOM_OBSOLETE is only set with --enable-application=minimo or with --disable-xpcom-obsolete.  No official Tinderbox configuration on the 1.8 branch uses --disable-xpcom-obsolete.  This can be verified with the following mxr searches:

http://mxr.mozilla.org/mozilla1.8/search?string=MOZ_NO_XPCOM_OBSOLETE
http://mxr.mozilla.org/mozilla1.8/search?string=disable-xpcom-obsolete&find=&findi=&filter=&tree=mozilla1.8

Because ifndef MOZ_NO_XPCOM_OBSOLETE is exactly equivalent to ifdef MINIMO, this patch has zero impact and is completely safe to take on the 1.8 branch.
Comment 1 Mark Mentovai 2007-12-18 18:37:04 PST
References to "ifdef MINIMO" in previous comment should be to "ifndef MINIMO."
Comment 2 Mark Mentovai 2007-12-18 18:37:55 PST
Created attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled
Comment 3 Mark Mentovai 2007-12-18 19:58:45 PST
Comment on attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled

We would like this on the 1.8 branch to be able to --disable-xpcom-obsolete for Camino.

As stated above, this change has no impact at all on any other product, because it replaces |ifndef MINIMO| with |ifndef MOZ_NO_XPCOM_OBSOLETE|, and on the 1.8 branch, MOZ_NO_XPCOM_OBSOLETE is only ever true when building minimo or when --disable-xpcom-obsolete is specified.  No currently known build ever specifies --disable-xpcom-obsolete.

This change was already made on the trunk on 2006-04-20.
Comment 4 Daniel Veditz [:dveditz] 2007-12-21 11:39:08 PST
Comment on attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled

Dougt: you OK with this change?
Comment 5 Doug Turner (:dougt) 2007-12-21 11:47:50 PST
Comment on attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled

I am okay with this.  it is good that the obsolete libs are dead.  maybe we should just stop building it?
Comment 6 Daniel Veditz [:dveditz] 2007-12-21 12:07:09 PST
Comment on attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled

approved for 1.8.1.12, a=dveditz for release-drivers
Comment 7 Mark Mentovai 2007-12-21 12:50:59 PST
Checked in on MOZILLA_1_8_BRANCH.
Comment 8 Doug Turner (:dougt) 2008-01-02 09:01:58 PST
Comment on attachment 293792 [details] [diff] [review]
Static builds should only link with xpcom-obsolete when it is enabled

marking +
Comment 9 Al Billings [:abillings] 2008-01-30 16:22:57 PST
Verified that it is checked in for 1.8 branch. Whee.

Note You need to log in before you can comment on or make changes to this bug.