If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download window and virus scanner file scanning loop

RESOLVED DUPLICATE of bug 401582

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 401582
10 years ago
9 years ago

People

(Reporter: paulflook@hotmail.co.uk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2


Mozilla Firefox 3 beta 1 & 2
Running on Microsoft xp sp2 and current updates (as of dec 18/07)

If you delete/cut/move a downloaded file before Firefox has a chance to finish its virus scan it leaves the downloaded file entry stuck in a permanent "scanning..." loop, these files cannot be cleared via normal privacy clear methods (screenshots can be provided). 

Reproducible: Always

Steps to Reproduce:
1.Download a 20mb file(or bigger, its only to give you time to delete the file whilst being scanned)
2.When its finished Firefox will then scan the file for virii
3.WHILST its scanning move or delete the file, the file will move/delete and the download window gets stuck in a "scanning loop"
Actual Results:  
The download manager window gets stuck and dispalys a scanning progress bar and the words scanning for viruses.....

sometimes download window displays blank, starting another download will redisplay the invalid entries.

Expected Results:  
If entries are moved then scanning should stop or file should be locked untill scanning finishes
(Reporter)

Comment 1

10 years ago
Created attachment 293820 [details]
Screenshot
Component: General → Download Manager
QA Contact: general → download.manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401582
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.