Absolutely positioned iframes have incorrect width

RESOLVED DUPLICATE of bug 412679

Status

()

RESOLVED DUPLICATE of bug 412679
11 years ago
11 years ago

People

(Reporter: chris87, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

When an iframe is positioned absolutely and both the left: and right: positions are specified, Fx3b2 (Gecko 20007121016) ignores the 'right' position and the resulting iframe has a width of around 200 pixels. <div>s are positioned as expected and as they are in Fx2 (Gecko 20071204).

Fairly minimal testcase at http://www.md87.co.uk/files/fx-bug-testcase.html - <iframe> is coloured green, <div> red (with opacity at 50% so you can see them both). Both elements are positioned identically, and should thus perfectly overlap. With Fx2 they overlap as expected, with Fx3 the iframe width is around 200 pixels, regardless of the width of the browser.

Reproducible: Always

Steps to Reproduce:
Position an iframe using position: absolute; left: 250px; right: 5px;
Actual Results:  
The iframe should be positioned so that its left-hand-side is at 250 pixels, and should be of such a width that the right-hand-side is 5 pixels from the RHS of the browser

Expected Results:  
The iframe is positioned so that its LHS is at 250 pixels, but the width is constant (around 200 pixels), regardless of the value of the 'right' attribute.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412679
You need to log in before you can comment on or make changes to this bug.