Save CSS Image url master @import

RESOLVED DUPLICATE of bug 115107

Status

RESOLVED DUPLICATE of bug 115107
11 years ago
2 years ago

People

(Reporter: webdesign.semnanweb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

many of web pages use the master css file that inlcluded the import code of any another css and they are also inlcue some images. this is the best way for css new technique. 
if fire fox find any url that css and background images that connected the main page. when user save the page save the all css of pages and images included in css files. that the pages save such as the web page proccess online.

but now firefox just save the main css and not url in css such as the images or another css files. in this example firefox just save the master.css and do not save the common.css, layouts.css and bodypic.jpg... if do it the pages save succesfully with all component. 

test the http://en.wikipedia.org/wiki/Firefox ... save that and open it the page is not the orginal page. :(

Reproducible: Always

Steps to Reproduce:
1.File must be saved with all css file that included in any css files with "@import url('another.css');" code, all css include with file must be saved
2.Images that included in any css files " background-image: url('myimg.jpg');" also must be save with the main html saved file.
Actual Results:  
when the user save file with this way all thing that they see in the online page will be save in his computer.

the page will be saved with all component. and never changing the styles of any way.

Expected Results:  
saved page such as the orginal page.

- CSS : Import another css file 
      : >> @import url("mycss.css"); /* CSS Importing */


- CSS : Import image in the root of css file in here
      : >> background-image: url("pics/mypic.jpg");

/* CSS Image
   Files : 
   ./
   ./mycss.css
   ./pics/mypic.jpg
 */

Comment 1

11 years ago
dupe of both Bug 115107 and Bug 126309
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: File Handling → File Handling
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 115107
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.