nsXPIDLString.cpp compile problem with on Linux/ia64

VERIFIED DUPLICATE of bug 40939

Status

()

P3
normal
VERIFIED DUPLICATE of bug 40939
19 years ago
18 years ago

People

(Reporter: jim_nance, Assigned: dp)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I have a problem building nsXPIDLString.cpp on an IA64 machine.
I am not sure if its a source code problem or a configure
script problem.  The compile dies with the error:

In file included from
/home/users/jnance/mbuild/mozilla/xpcom/ds/nsXPIDLString.cpp:25:
/home/users/jnance/mbuild/mozilla/xpcom/ds/nsXPIDLString.h: In function `PRBool
operator== (const PRUnichar *, const nsXPIDLString &)':
/home/users/jnance/mbuild/mozilla/xpcom/ds/nsXPIDLString.h:201: static_cast from
`const nsXPIDLString' to `const PRUnichar *'

and several other warnings about casts.  If I go into the
config-defs.h file generated by configure an undef HAVE_CPP_NEW_CASTS
then the build works.  I do not know if the source is wrong
or if the configure script should detect this problem.
(Reporter)

Comment 1

19 years ago
Sorry, I entered this one twice :-(

*** This bug has been marked as a duplicate of 40939 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
marking as verified/duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.