Fixed elements can overwrite scrollbar

VERIFIED DUPLICATE of bug 5195

Status

P3
normal
VERIFIED DUPLICATE of bug 5195
19 years ago
10 years ago

People

(Reporter: jsp, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m16) Gecko/20000529
BuildID:    2000052908

A fixed DIV with a width of 100% and a background color specified overwrites
part of the main scrollbar (assuming one is required).  If no background color
is specified, the scrollbar is initially drawn correctly, but breaks up if the
thumb is moved.	

Reproducible: Always
Steps to Reproduce:
Put the following HTML into a file, then load the file into Mozilla:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
<HEAD>
<STYLE type="text/css">
#header
{
position: fixed;
width: 100%;
top: 0;
height: 60px;
background: yellow;
}
#main
{
position: relative;
top: 60px;
}
</STYLE>
</HEAD>
<BODY>
<DIV id="header">Some text.</DIV>
<DIV id="main">
<P>Paragraph 1.</P>
<P>Paragraph 2.</P>
<P>Paragraph 3.</P>
<P>Paragraph 4.</P>
<P>Paragraph 5.</P>
<P>Paragraph 6.</P>
<P>Paragraph 7.</P>
<P>Paragraph 8.</P>
<P>Paragraph 9.</P>
<P>Paragraph 10.</P>
<P>Paragraph 11.</P>
<P>Paragraph 12.</P>
<P>Paragraph 13.</P>
<P>Paragraph 14.</P>
<P>Paragraph 15.</P>
<P>Paragraph 16.</P>
<P>Paragraph 17.</P>
<P>Paragraph 18.</P>
<P>Paragraph 19.</P>
<P>Paragraph 20.</P>
<P>Paragraph 21.</P>
<P>Paragraph 22.</P>
<P>Paragraph 23.</P>
<P>Paragraph 24.</P>
<P>Paragraph 25.</P>
<P>Paragraph 26.</P>
<P>Paragraph 27.</P>
<P>Paragraph 28.</P>
<P>Paragraph 29.</P>
<P>Paragraph 30.</P>
</DIV>
</BODY>
</HTML>

If you don't have a vertical scrollbar on the main window, resize the window
until you do.  (The second <DIV> is just there to fill up the window, but your
mileage may vary.)

Actual Results:  The yellow <DIV> extends all the way to the window frame,
overwriting the top of the scrollbar.

Expected Results:  The yellow background should have extended to the inside edge
of the scrollbar.  That is, it should have been contained inside the client area.	

Might be related to bug 4209.

Comment 1

19 years ago
This is actually bug #5195. Thanks.

*** This bug has been marked as a duplicate of 5195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verifying
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.