Flash hangs if tab is switched and/or browser isn't the current selected program.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: hragatron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

I noticed this when I was listening to a song on Myspace. I minimized the browser, and the music stopped... then brought it back up and it resumed. I repeated this and it did the same thing every time. I also tested to see if the same thing happened when I switched tabs and sure enough, it did.

Not a major bug, but a lot of people do use the browser to listen to music and leave it running in the background. So far FF3 is awesome.

cheers!

Reproducible: Always

Steps to Reproduce:
1. Open a myspace page with music (www.myspace.com/strata for example)
2. Listen to any song.
3. Switch tab or minimize window
4. Switch back to the tab or maximize window
Actual Results:  
The music stops and resumes when the tab is switched or window isn't focused.

Expected Results:  
the music to continue playing.
I can't reproduce with Shockwave Flash 9.0 r115 on Windows XP SP 2; which version of Flash are you using?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> I can't reproduce with Shockwave Flash 9.0 r115 on Windows XP SP 2; which
> version of Flash are you using?
> 

heya. just took a look, i'm running flash verion 9.0.47. lemme upgrade and see what happens.
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > I can't reproduce with Shockwave Flash 9.0 r115 on Windows XP SP 2; which
> > version of Flash are you using?
> > 
> 
> heya. just took a look, i'm running flash verion 9.0.47. lemme upgrade and see
> what happens.
> 
hey again, i upgraded to r115 and it works fine. 

thanks! cheers!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.