Browser doesn't render page correctly

VERIFIED DUPLICATE of bug 40143

Status

()

P3
normal
VERIFIED DUPLICATE of bug 40143
19 years ago
19 years ago

People

(Reporter: jmbelo, Assigned: pierre)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
In page apears the following text "A.NAV { COLOR:#000000; TEXT-DECORATION:NONE } 
A.newsflash { COLOR:#339999 } BODY {font-family: Helvetica, Arial; }" (TOP PAGE)
and ".marketLink { font-family: Verdana, Arial, Helvetica; color:"#000099"; 
font-size:10px; line-height:11px; line-width:120px } .marketHeader {" ( RIGHT 
PAGE )

Allways appens, in Build ID 2000051920 W20000, also appens in other pages in 
http://scifi.ign.com/

To test it go to "http://scifi.ign.com/comics/4584.html"

Comment 1

19 years ago
*** Bug 40968 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
I am experiancing this on Linux, but I wasen't very effective at coming up with
a test case. I'm pretty clueless about anything inside a <script>. My guess
would be incorrect javascript not inside a comment, however. Maybe someone in
the right department can confirm or invalidate this...
Component: Browser-General → Javascript Engine
OS: Windows NT → All

Comment 3

19 years ago
I see this also.  Basically what's happening here is:

Using document.write, the page writes <style type=\"text/css\"> to designate 
CSS.  Then it checks the browser by examining the first 9 letters of the 
appname.  If such letters are "Microsoft", it writes a whole bunch css to the 
page via document.write   Otherwise, if the letters are anything else (which it 
would be, in our case), it writes some different CSS to the page using:

document.write("	A.NAV { COLOR:#000000; TEXT-DECORATION:NONE }");
document.write("	A.newsflash { COLOR:#339999 }");

Then, regardless of the browser, it adds:

document.write("	BODY {font-family: Helvetica, Arial; }");
document.write("</style>");

This _seems_ valid enough to me.  It defines the script as CSS, writes some 
basic CSS, and then closes it with the </style> tag.  Perhaps this is a dup of 
a more general bug, but what's wrong here?  cc'ing rickg (parser), but 
reassigning to style system - if there's a problem here, it's probably CSS-
related
Assignee: asadotzler → pierre
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Style System
Ever confirmed: true
QA Contact: jelwell → chrisd

Comment 4

19 years ago

*** This bug has been marked as a duplicate of 40143 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
yep
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.