ACID 2 Rending: Antialiasing the nose

RESOLVED DUPLICATE of bug 343583

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 343583
10 years ago
10 years ago

People

(Reporter: Kevin Hollenshead, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

While comparing the ACID 2 rendering of 3.0b2 to the reference, I noticed a discrepancy in the rendering of the nose.  I grabbed screenshots and compared and noticed that the nose appears to be antialiased in the FF rendering but not in the reference rendering.

At a normal resolution, the image almost appears to be a pixel's width too small.

Reproducible: Always

Steps to Reproduce:
1. Execute the ACID 2 rendering
2. Compare to the reference rending image



I reviewed the technical guide on the ACID2 test but did not see anything immediately that covered this in this level of detail. My understanding was that, other than font metrics, etc., that the reference rendering was to be an absolute pixel by pixel match.
(Reporter)

Comment 1

10 years ago
Created attachment 294488 [details]
Rendering comparison

Comment 2

10 years ago
Acid 2 does not require perfect pixel matching for the nose.  See bug 343583 comment 6.  (Hixie is the creator of the Acid 2 test.)
Blocks: 289480
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk

Comment 3

10 years ago
Indeed, this was discussed and resolved as invalid in bug 343583 already -> dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 343583

Comment 4

10 years ago
Note to Hixie: if you are still in control of the test, please update reference.png to the attachment 294110 [details] one.
The antialiasing of the nose is not defined by CSS; the reference image I posted is no more valid than the one linked in the test.
You need to log in before you can comment on or make changes to this bug.