acid2 fails when bidi.direction set to 2 (rtl mode).

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: is+mozilla, Unassigned)

Tracking

(Blocks: 1 bug, {rtl})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.8.1.8) Gecko/20071004 Iceweasel/2.0.0.8 (Debian-2.0.0.8-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122504 Minefield/3.0b3pre

I thought firefox was misrendering the acid2 test, even thought the latest reports are that it should pass.  I started a new profile and than firefox passed. Testing different configs, I finally identified bidi.direction as the culprit. 

I apologize if this is a bug in the test rather than firefox, but I'm not an expert in such things. 

Reproducible: Always

Steps to Reproduce:
1. Create a new profile.
2. Change bidi.direction to 2 in about:config 
3. Restart firefox and take acid2 test. 
Actual Results:  
Half of the lines are quasi-left justified (they are a fixed distance from the left border but are not flush with it), the other half are right-justified. See attached screenshot. 

Expected Results:  
I should see a beautiful smiley face.
(Reporter)

Comment 1

10 years ago
Created attachment 294557 [details]
screen shot of acid rendered with bidi.direction=1

Updated

10 years ago
Blocks: 289480
I think this is INVALID. See the second Note at http://www.webstandards.org/action/acid2/ -- "When taking the test, you should use the default settings of the browser you are testing."
(Reporter)

Comment 3

10 years ago
Yes, it is invalid. It turns out the setting about:config is no longer the correct way to set UI direciton, all this stuff having moved into higher magic in the locale.  I've finally gotten a Hebrew nightly to start (they've been broken for the last couple of weeks), and Acid2 works just fine once all about:config variables are restored to default values. 

Sorry for the inconvinience. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.