Freezing script at Firefox startup (it has something to do with the ExtensionManager)

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: compu_rick666, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

Hello everyone,

Let's get straight to the point: A script in Firefox freezes at startup. For dutch people, see below, for people with other languages, i'll do my best to translate:

"Een script op deze pagina is bezig, of het reageert niet meer. U kunt het script nu stoppen, of u kunt verdergaan om te zien of het script zal worden voltooid.

Script: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%202/components/nsExtensionManager.js:2097"

English translation:

"A script is busy on this page, or it doesn't react anymore. You can stop the script now, or you can continue to see if the script will complete.

Script: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%202/components/nsExtensionManager.js:2097"

For your information: I've had this problem already in Firefox 2.0.0.9, I didn't do anything strange, I barely use extensions, I'm Dutch and a very bad translator. Also please note that probably nobody else has this problem, what means that this is less inportant than other problems.

Thanks in advance,
... eh... Somebody. :P

Reproducible: Always

Steps to Reproduce:
1. Do something (i don't know what) to your extensions.
2. Startup Firefox.
3. Ask some people what's happening.
Actual Results:  
A script freeze.

Expected Results:  
Fixed the script.

i have:
-Windows XP
-Dual screen(probably doesn't matter)
-Direct X 9.0C (who hasn't in 2007/2008?)
-Firefox 3 Beta 2
-No idea what's going on
-No trace of Talkback crash ID or something like it
Dpes it work in the Firefox safemode ?
(Reporter)

Comment 2

11 years ago
You know, doing that just once solved the whole problem... I'll explain what i did:

-Start in safemode
-Script freezed... "Stop script"
-*What do you want to do menu pops up*
-Clicked "Disable all add-ons"
-Enabled "DOM Inspector" AND "Download Accelerator Plus Integration" again
-Still worked? (Note that "DOM" and "DAP" where my ONLY add-ons)

Seems like somehow the file was corrupted by an add-on I had a while ago, and that Safemode reset it. Thank you VERY much for your help, may i encounter this again, i know what to do ;-)

*FIXED*
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Problem was caused by a third party addon - INVALID
Resolution: FIXED → INVALID
(Reporter)

Comment 4

11 years ago
POSSIBLY, i still don't know for sure
You need to log in before you can comment on or make changes to this bug.