Tooltips with long text don't stay up long enough

VERIFIED DUPLICATE of bug 395668

Status

VERIFIED DUPLICATE of bug 395668
11 years ago
8 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122702 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122702 SeaMonkey/2.0a1pre

Tooltips in SeaMonkey always stay up for about 5 seconds, regardless of the length of the text. This isn't long enough if the text is long, as is often the case with Bugzilla links to bugs with long summaries

Reproducible: Always

Steps to Reproduce:
1. Hover your mouse over the following link: bug 79130 (any link with a long tooltip will do)

Actual Results:  
Tooltip stays up for about 5 seconds

Expected Results:  
Tooltip should stay up long enough to be read

Additional info: see bug 45375 comment #137

I see two approaches for fixing this bug:
(a) Make the tooltip display time a function of its text length, maybe a linear function   t = a + b*l   where a and b are constants and l is the length;
(b) Make the tooltip display time user-settable via about:config.
--- Both approaches are not necessarily exclusive: there could even be two prefs, maybe browser.tooltip.latency (or something), current value 5 (seconds) or 5000 (milliseconds); and browser.tooltip.timeRatio (or something), current value zero (milliseconds per byte).
Version: unspecified → Trunk
Adding David E Ross to CC list because I believe he would be interested.

Comment 2

11 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
This was originally proposed in bug 45375 but not implemented.  See the
comments in that bug report starting with 137.  Note that a number of the
subsequent comments there also requested longer display times for longer
tooltips.  This is still a good idea.  

However, for user orientation, I would make the parameters seconds and not
milliseconds.  That would change the formula to something like t = a + b*l/5,
the 5 being the convention in typing tests (many, many years ago) that, on
average, one word equals 5 characters.  Then the a is still latency. and the b
is seconds per word.  Since we can often read well more than 60 words per
minute, it might even be t = a + b*l/50, in which case b would be seconds per
10 words.  In any case, for the general users, I would avoid milliseconds.  
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design

Comment 5

10 years ago
I heard from someone that Firefox 3.6a1pre keeps showing the tooltip for infinite time until mouse is removed. 

Should be checked out.

Comment 6

9 years ago
This was fixed for Firefox in bug 395668.

Comment 7

9 years ago
I have tried FF3.6b5 (linux) and the issue still there.

Comment 8

8 years ago
Fixed in Core by Bug 395668
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395668
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.