Session Cookies are not removed, if FF Start option is 'Display Windows & Tabs of the last Session'

RESOLVED DUPLICATE of bug 529899

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 529899
11 years ago
a year ago

People

(Reporter: HansHuckebein, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11

I'm using the german localization of FF, so I use the german navigation texts, where I don't know the english labels, sorry.

Settings: 
Edit|Datenschutz|Settings|Datenschutz|Cookies: Select Session Cookies
Edit|General|Start: Select 'Display Windows & Tabs of the last session' (3rd choice)

If you terminate FF and restart it, all session cookies of the previous run are still present.

This might be formally correct, if these settings simply mean 'Continue last session', but it suggests the naive user, that session cookies are removed.

Reproducible: Always

Steps to Reproduce:
FF Settings:
1.Edit|Datenschutz|Settings|Datenschutz|Cookies: Select Session Cookies
2.Edit|General|Start: Select 'Display Windows & Tabs of the last session' (3rd choice)
3. Open some site, that places cookies
4. Open Cookie manager and remember the present cookies
5. Terminate FF
6. Restart FF
7. Open Cookie manager - the cookies are still present
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
See bug 401187 comment #5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401187
You need to log in before you can comment on or make changes to this bug.