need to add CSS font-stretch to nsFont

VERIFIED DUPLICATE of bug 3512

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 3512
20 years ago
14 years ago

People

(Reporter: Erik van der Poel, Assigned: Pierre Saslawsky)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
I'm implementing Unicode and some of CSS on Unix, and I bumped into the lack
of the CSS font-stretch info in nsFont. X has long font names that include
the stretchiness, and it would be nice if we could pass the font-stretch
property down to GFX to select the appropriate font(s).

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M7

Comment 1

19 years ago
Bug #3512 was related to font-stretch not being functional. Peterl comments:
'CSS2 feature that was never promised. Don't know if font code can even deal
with it.'

That bug has not yet been marked resolved. Don't know if this is the same issue
but putting in comments FYI.

Updated

19 years ago
Target Milestone: M10 → M11

Comment 2

19 years ago
Pushing off non-beta 1 issues
(Assignee)

Comment 3

19 years ago
Reassigning peterl's bugs to myself.
(Assignee)

Comment 4

19 years ago
Accepting peterl's bugs that have a Target Milestone
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
As chrisd said, this is a dup of #3512. The font stretch property is parsed but
we don't do anything with it in MapDeclarationFontInto() because it's not defined
in nsFont.


*** This bug has been marked as a duplicate of 3512 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Verified dup of #3512
You need to log in before you can comment on or make changes to this bug.