Last Comment Bug 410107 - Color (colour) codes preceding a URL are ignored
: Color (colour) codes preceding a URL are ignored
Status: RESOLVED FIXED
[cz-0.9.80]
: regression
Product: Other Applications
Classification: Client Software
Component: ChatZilla (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: :Gijs Kruitbosch
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 14:14 PST by James Ross
Modified: 2008-01-05 15:40 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.59 KB, patch)
2008-01-05 08:41 PST, :Gijs Kruitbosch
bugzilla-mozilla-20000923: review+
Details | Diff | Splinter Review

Description James Ross 2007-12-28 14:14:32 PST
A rather fun bug reported on IRC. If you stick a colour code right up against the start of a URL, it doesn't get found, e.g.:

  %C0http://example.com

This is a pain, since bug 371109 stopped codes anywhere in URLs, but at the start should be possible I think (I'd like it to work at the end too, but that's impossible to get right).

This could be fixed by adding "(index == 0) ||" to the ternary operator here:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/extensions/irc/xul/content/static.js&rev=1.254&mark=2785#2777
Comment 1 :Gijs Kruitbosch 2008-01-05 08:41:27 PST
Created attachment 295515 [details] [diff] [review]
Patch

As you wish. :-)
Comment 2 :Gijs Kruitbosch 2008-01-05 15:40:19 PST
Checking in mozilla/extensions/irc/xul/content/static.js;
/cvsroot/mozilla/extensions/irc/xul/content/static.js,v  <--  static.js
new revision: 1.256; previous revision: 1.255
done

Note You need to log in before you can comment on or make changes to this bug.