Full Zoom: Image zoom and layout zoom should match

VERIFIED FIXED

Status

Core Graveyard
GFX
--
enhancement
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

10 years ago
Created attachment 294840 [details]
image_zoom_issue.png

Full Zoom: Image zoom and layout zoom should match

This is not a major issue but good enough to cause a 1 pixel issue on layout while zooming.

Steps:-
1. go to http://www.reactos.org/en/screenshots.html
2. start full  zoom
3. user will start seeing minor aliment issue on the menu

see image_zoom_issue.png

Comment 1

10 years ago
I dont see this with Firefox 3 beta 2 on Mac OS X 10.5 and also not in Windows XP using latest trunk build.
(Reporter)

Comment 2

9 years ago
Created attachment 333338 [details]
youtube.png

Issue reduced but still exist on 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre)
Gecko/20080808031528 Minefield/3.1a2pre

See you tube and gmail attachment
(Reporter)

Comment 3

9 years ago
Created attachment 333339 [details]
gmail.png

Comment 4

9 years ago
Do we know what, exactly, the problem is here? Either this is something broken in Core, or it's a site issue, but I don't think it's both, and it's not clear to me why this was filed as NEW in the first place.
(Reporter)

Comment 5

9 years ago
Created attachment 334219 [details]
gmail_icons1c.png

May be this is two bugs, but when I submitted the GMail screen I thought they are same.  

This is what I think now about what happening...
GMail serve all the icons as 
http://mail.google.com/mail/images/2/5/c/icons1c.png
http://mail.google.com/mail/images/2/icons_ns2a.png
and may be doing a clip rectangle.

Now when we zoom we may have to created pixels at the border of icons using the pixels from outside of original rectangle.

So when zoom we may have to do this.
1. first cut out the clipped rectangle area  
2. then start zooming.

This is a guess I have not read the code.
If my assumption is right let me know I will file 
another bug/enhancement for this.
(Reporter)

Comment 6

9 years ago
Created attachment 334220 [details]
gmail_icons_ns2a.png
(Reporter)

Comment 7

9 years ago
(In reply to comment #5)
> Now when we zoom we may have to created pixels at the border of icons
> using the pixels from outside of original rectangle.
oops..

Now when we zoom we may be creating pixels at the border of the resulting image using the pixels from outside of the original clipped rectangle.

So a fix to this issue may be...
when we zoom, we may have to...
1. first cut out the clipped rectangle area to be zoomed
2. then zoom only/separately that image area and display it.

(Reporter)

Comment 8

9 years ago
Should be fixed by bug 458487
Per comment bug 446100 Comment 26
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 458487
Resolution: --- → FIXED

Comment 9

9 years ago
Confirmed. Verified fixed with current nightly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081109 Minefield/3.1b2pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.