content that should be flex 50% is showing empty

VERIFIED FIXED

Status

()

Core
XUL
P3
critical
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Syd Logan, Assigned: Gary Frattarola)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][dogfood-])

(Reporter)

Description

18 years ago
Getting asserts in box code.

###!!! ASSERTION: SetBounds Size < 0: 'aRect.width >=0 && aRect.height >= 0',
file nsBox.cpp, line 484
###!!! Break: at file nsBox.cpp, line 484
###!!! ASSERTION: Content Size < 0: 'aContentRect.width >=0 &&
aContentRect.height >= 0', file nsBox.cpp, line 468
###!!! Break: at file nsBox.cpp, line 468
###!!! ASSERTION: SetBounds Size < 0: 'aRect.width >=0 && aRect.height >= 0',
file nsBox.cpp, line 484
###!!! Break: at file nsBox.cpp, line 484
###!!! ASSERTION: Content Size < 0: 'aContentRect.width >=0 &&
aContentRect.height >= 0', file nsBox.cpp, line 468
###!!! Break: at file nsBox.cpp, line 468

For steps, see http://bugscape/show_bug.cgi?id=1063
(Reporter)

Comment 1

18 years ago
Marking dogfood, since IM has a dogfood bug that depends on this.
Keywords: dogfood
(Reporter)

Comment 2

18 years ago
taking out editor did not help

Comment 3

18 years ago
Syd,

I'll try to pull the commercial build to check it out. What were the steps on 
windows?
Status: NEW → ASSIGNED

Comment 4

18 years ago
Yes, IM depends on this fix for the following dogfood bug:

http://bugscape/show_bug.cgi?id=1063

Comment 5

18 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]

Comment 6

18 years ago
Have fix testing.
Whiteboard: [dogfood+] → [dogfood+] 5/31/00

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
fixed
(Reporter)

Comment 8

18 years ago
Assert seem to have gone away, but our flex settings are still not being honored
on Linux.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Getting asserts from box, content that should be flex 50% is showing empty → content that should be flex 50% is showing empty

Comment 9

18 years ago
removing dogfood+ for reconsideration.  This may only happen in AIM, and there 
is a workaround (resize the window), although it may not be obvious.  adding 
relnote,nsbeta2 keywords.
Keywords: dogfood
Whiteboard: [dogfood+] 5/31/00
(Reporter)

Comment 10

18 years ago
Keywords didn't seem to get added. The bug this relies in in bugsplat is still
dogfood+
Keywords: nsbeta2, relnote

Comment 11

18 years ago
The IM bug this depends on is dogfood because it appears to users that you cannot 
type in the send IM window (because the compose area is collapsed).  This is a 
serious useability issue.
Keywords: relnote → dogfood

Comment 12

18 years ago
[nsbeta2+
Whiteboard: [nsbeta2+]

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+][dogfood-]
(Reporter)

Comment 13

18 years ago
Renominating since bugscape bug that depends on this is dogfood+.

The following script can be used to backout changes made on 5/25/00 at around
11:43. I have not attempted to pin this to one of files since I believe this
might be difficult. I had to pull 05/26/00 04:00 (e.g., cvs co -D "05/25/2000
04:00:00" to get a build that I could then apply this too. Don't try to undo on
a current tree, seems there have been enough changes to make this difficult. 

cvs update -j3.239 -j3.238 mozilla/layout/html/base/src/nsFrame.cpp
cvs update -j3.50 -j3.49 mozilla/layout/html/base/src/nsGfxScrollFrame.cpp
cvs update -j1.148 -j1.147 mozilla/layout/html/base/src/nsScrollFrame.cpp
cvs update -j3.79 -j3.78 mozilla/layout/html/document/src/html.css
cvs update -j1.134 -j1.133
mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp
cvs update -j1.42 -j1.41
mozilla/layout/html/forms/src/nsGfxListControlFrame.cppcvs update -j1.449
-j1.448 mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
cvs update -j1.46 -j1.45 mozilla/layout/xul/base/src/nsSplitterFrame.cpp
cvs update -j3.33 -j3.32 mozilla/view/public/nsIScrollableView.h
cvs update -j3.132 -j3.131 mozilla/view/src/nsScrollingView.cpp
cvs update -j3.125 -j3.124 mozilla/view/src/nsView.cpp
cvs update -j1.28 -j1.27 mozilla/view/src/nsViewManager2.cpp
cvs update -j1.120 -j1.119 mozilla/xpfe/global/resources/skin/xul.css
Whiteboard: [nsbeta2+][dogfood-]

Updated

18 years ago
Whiteboard: [nsbeta2+][dogfood-]

Comment 14

18 years ago
This does not stop us from using the app.  Thus we will make this 
[nsbeta2+][dogfood-]

Comment 15

18 years ago
Ok I can't reproduce this because I can't log into IM. I followed the instuction 
on the attached but bug I never get a log in screen. 

Comment 16

18 years ago
Gary another one you can look at.
Assignee: evaughan → garyf
Status: REOPENED → NEW
(Reporter)

Comment 17

18 years ago
Fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
verified
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.