Page layout issue on State Dept. site

VERIFIED DUPLICATE of bug 384616

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 384616
11 years ago
10 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008010204 Minefield/3.0b3pre.

STR:
1. Navigate to site listed in URL field.
2. Observe page layout.

This page lays out properly using Safari. I see the same layout issue using the latest branch nightly.

Comment 1

11 years ago
http://validator.w3.org/check?uri=http%3A%2F%2Ftravel.state.gov%2Ftravel%2Frequirements%2Frequirements_1233.html&charset=%28detect+automatically%29&doctype=Inline&group=0

Using a branch Seamonkey and am Opera 9.24 the site doesn't look fine, so I used w3c validator.

Of course site doesn't validate as there are things like missing 'alt' attributes, but there are also more serious errors, and some MS specifics.

value of attribute "ID" must be a single token:
<input id="search input" ...
<a id="imgCongressionial Liaison">

Line 202, Column 213: document type does not allow element "BR" here; assuming missing "LI" start-tag.
Line 202, Column 408: document type does not allow element "BR" here; assuming missing "LI" start-tag.

view-source:http://travel.state.gov/travel/requirements/requirements_1233.html

</li><br><li> the <br> is invalid according to validator.w3.org 
Duplicate of bug 384616, this is a tech evangelism issue, as the site in question use some user agent detection to link to different urls for the stylesheets they are using. But for Mozilla they forgot to upload something.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384616

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.