task/event to eMail conversion -> subject gets a leading 'Re:'

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: andreas.treumann, Assigned: maxxmozilla)

Tracking

unspecified
Bug Flags:
wanted-calendar0.8 +

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

12 years ago
STEPS TO REPRODUCE:
===================

- convert a task or event into an eMail
- check the subject of this eMail

RESULT:
=======

- the subject of this eMail is the event title with a leading 'Re:'

EXPECTED RESULT:
================

- the subject should be the event title without the 'Re:' 

REPRODUCIBLE:
=============

- always

Comment 1

12 years ago
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.9 ID:2007103104, Lightning 20080205
Flags: wanted-calendar0.8?
Version: Trunk → unspecified
VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008010520) Thunderbird/2.0.0.9 ID:2007103104
Little copy&paste error, the verified means confirmed ;-)
Not going to happen for 0.8.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
Assignee

Comment 5

12 years ago
Tested on Lightning 0.8pre (build 2008021620)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071031
Thunderbird/2.0.0.9 ID:2007103104
Assignee: nobody → firefox
Status: NEW → ASSIGNED
Attachment #304100 - Flags: review?(philipp)
Comment on attachment 304100 [details] [diff] [review]
Removes 'Re:' from the subject


>-emailSubjectReply=Re: %1$S
>+emailSubjectReply=%1$S

No use in having a string that is just a parameter. Please remove this string completely and change the calling code to directly use the parameter.

This will be a post-0.8 bug due to string change.
Attachment #304100 - Flags: review?(philipp) → review-
http://lxr.mozilla.org/mozilla1.8/search?string=emailSubjectReply

This string is used in multiple locations, e.g. if you want reply to the organizer of an invitation or compose an email message from the event dialog. In this case the Re: should probably preserved.

But I agree that for the event creation it doesn't make much sense. In this case only http://lxr.mozilla.org/mozilla1.8/source/calendar/base/content/calendar-dnd-listener.js#450 ff. could be changed to directly use the title.
Assignee

Comment 8

12 years ago
Philipp, Andreas, what do you think about Stefan proposal ?
Yes, Stefan's proposal makes sense. I wasn't aware the string was used in other cases.
In this case, we could even take this for 0.8, given ready in the next few days.
Assignee

Comment 11

12 years ago
Posted patch Proposed fix (obsolete) — Splinter Review
Updated to comments.
Attachment #304100 - Attachment is obsolete: true
Attachment #304329 - Flags: review?(philipp)
Assignee

Updated

12 years ago
Flags: wanted-calendar0.8- → wanted-calendar0.8?
Comment on attachment 304329 [details] [diff] [review]
Proposed fix


>-            var subject = calGetString("sun-calendar-event-dialog",
>-                                       "emailSubjectReply",
>-                                       [item.title]);
>+            var subject = item.getProperty("SUMMARY");
> 
>             // set up message body from item description
>             var body = item.getProperty("DESCRIPTION");
> 
>             sendMailTo(recipients, subject, body);

I'd suggest dropping the subject variable altogether and passing item.tite (not via getProperty) to sendMailTo directly.

r+ with this changed, I can do so before checkin if you agree.


>         }
>     },
>
Attachment #304329 - Flags: review?(philipp) → review+
Flags: wanted-calendar0.8? → wanted-calendar0.8+
Assignee

Comment 13

12 years ago
Dropped subject variable.
Carrying over r+
Attachment #304329 - Attachment is obsolete: true
Attachment #304562 - Flags: review+
Almost, the [] are too much. Fixed this before checkin.

Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Assignee

Comment 15

12 years ago
> Almost, the [] are too much.
yeah, but I saw [item.title] used in a few other places so...

-> VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008022119) Thunderbird/2.0.0.9 ID:2007103104
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.