Bugmail Email Header fields doesn't make sense (and makes my mail client confused)

RESOLVED WORKSFORME

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: zwnj, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
Gmail has a cool feature, Muting, which allows user to archive a thread, and all its future mails.  But it doesn't archive a mail if user is on the To or CC fields. (Though the thread will have the "Muted" label yet)

Bugzilla could have an option to not put user's email address in To or CC, and just use something like bugNUMBER@bugzilla.

Comment 1

10 years ago
If you don't want to get bugmail, you can disable it from the "preferences" panel.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> If you don't want to get bugmail, you can disable it from the "preferences"
> panel.

I think you didn't get it.  I wanna get bugmails and I do read them.  But there are some bugs that I don't want/need to follow up.

When I'm "watch"ing a maintainers alias, I get *all* mail for the alias.  So being a maintainer forces me to "read the topic, remember if I was interested in this bug, select if so, and archive" a lot of mails each day.

That is my current problem.

BTW I requested for a generic option.  It helps me to solve this problem, and maybe some other problems too.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

10 years ago
(In reply to comment #2)
> I wanna get bugmails and I do read them.  But there
> are some bugs that I don't want/need to follow up.

So what you want is bug 148564.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 148564
(Reporter)

Comment 4

10 years ago
That's close.  But it's about having an option on the bugzilla, and maintaining the option should be on the buzilla system.  What I requested is how I prefer to get bugmails.

Well, here are the logical view.  "Am I the "To" person of every comment of every bugmail I get?"  Of course the response is "No".  When we only had the CC list, it was partly true.  But when we have Watch list, this is not true anymore.  That's because having some module@example.bugs on the Watch list is more like being in a mailing-list.

Ok, it's time for conclusion. When I'm in Assignee/QA/CC (and other similar) fields, I'm the "To" contact of the email, but when I'm not on those list, I am NOT a "To" contact.  If I wanna make it better, it would be: When I'm the Assignee or QA, I'm the "To" contact.  When I'm on the CC list, I'm a "CC" contact, and otherwise, I'm just getting the email to be aware of its existence, so I'm a "BCC" contact.

Does it make sence now?  If you accept this logic, I can try to do the coding part myself.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Allow bugmail to be muted → Bugmail Email Header fields doesn't make sense (and makes my mail client confused)

Comment 5

10 years ago
(In reply to comment #4)
> Does it make sence now?

No. You want to watch some user, so you accept to be the "To" guy and get bugmail accordingly. If you don't want to get bugmail, stop watching other users. Else use filters in your email client to use the X-Bugzilla-Reason which contains exactly the information you want.

So this bug is either "Works For Me" or still a dupe of bug 148564.

Comment 6

10 years ago
Oh, and about the new summary of this bug "Bugmail Email Header fields doesn't make sense (and makes my mail client confused)", I don't see why it's confusing. We all use them to filter emails, for months, and it works fine.

Comment 7

10 years ago
Well, I can use what behnam asks for to.  I colorize my mail based on whether my address is in To or CC.  That way I quickly see if a mail is from a mailing list or directly addressed to me.  Bugzilla mail always looks like directly addressed to me...  Sure, I asked to get it, the same way as I asked to get the mailing list mail.
(Reporter)

Comment 8

10 years ago
> Oh, and about the new summary of this bug "Bugmail Email Header fields doesn't
> make sense (and makes my mail client confused)", I don't see why it's
> confusing.

Does Bugmail use "CC" field of email at all?  AFAIK it doesn't.  We have a "CC" list in bugzilla, and we don't use the "CC" field of email header; this seems *wrong* to me.

> No. You want to watch some user, so you accept to be the "To" guy and get
> bugmail accordingly. If you don't want to get bugmail, stop watching other
> users.

You mean I should stop watching "persian-fa@localization.bugs" to get myself out of conversations on some bugs?

Also I watch a lot of people, because their work is so related to my work.  This way I can get get at least 25% of my future search results right in my inbox, right when the conversation is hot.

> Else use filters in your email client to use the X-Bugzilla-Reason which
> contains exactly the information you want.

> We all use them to filter emails, for months, and it works fine.

You're partly right. X-Bugzilla works someway.  But I need to add rules on X-Bugzilla-Reason to do something that could have been done on the server.

What about Gmail that doesn't let me change the value of To field, before it applies its own rules?

> So this bug is either "Works For Me" or still a dupe of bug 148564.

I don't wanna be rude, but we don't have "bugzilla points" here, as we have on bugzilla.gnome.org, and it's my second "product: Bugzilla" bug report in years, so I don't know you, if you are a master hacker, a new maintainer, or someone interested.

Comment 9

10 years ago
(In reply to comment #8)
> Does Bugmail use "CC" field of email at all?  AFAIK it doesn't.  We have a "CC"
> list in bugzilla, and we don't use the "CC" field of email header; this seems
> *wrong* to me.

This doesn't look wrong at all. The CC list of a bug and the CC field of an email are two different things. Moreover, X-Bugzilla-Reason gives you this information already.


> Also I watch a lot of people, because their work is so related to my work. 
> This way I can get get at least 25% of my future search results right in my
> inbox, right when the conversation is hot.

So use filters in your email client so that you don't loose any information. X-Bugzilla-Watch-Reason gives you additional information to filter emails in an even better way. Thunderbird (among others) does it very nicely. If Gmail doesn't let you play with filters, that's not a Bugzilla limitation.


> You're partly right. X-Bugzilla works someway.  But I need to add rules on
> X-Bugzilla-Reason to do something that could have been done on the server.
> 
> What about Gmail that doesn't let me change the value of To field, before it
> applies its own rules?

As said above (and in another bug already), that's not a Bugzilla limitation, but a Gmail one.


> so I don't know you, if you are a master hacker, a new maintainer, or someone
> interested.

I'm the QA lead and one of the four managers (with justdave, myk and mkanat) of the Bugzilla product, a developer and reviewer, see http://www.bugzilla.org/developers/profiles.html. I discussed this bug on IRC, and another developer agrees with me that this bug is WFM. So marking as such again (and I hope for the last time).
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.