Unify Stop and Reload button for all platform, like Safari behavior

VERIFIED DUPLICATE of bug 343396

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 343396
10 years ago
10 years ago

People

(Reporter: NicolasWeb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

Combine Stop button with Reload button haven't been ever done in Fx. Fx Goals have always been, and are user-oriented and simplify things for day-to-day users (not to add and add functionality). So as we do not use both stop and reload buttons at the same time, it is inconsistent to keep them both. That's confusing for users. I think that these 2 buttons are "hey, what's happen here, then click" for users. Both refers to content load and progress. This should be simplified.
This meet os integration too in OS X.
With this we can win area for control that give important information to the user, surely location bar.

Reproducible: Always

Steps to Reproduce:
1.Type a web site's address
2.Load it
3.Ask you when loading if you need to refresh the page
4.Ask you when loaded if you need to stop to load the page
Actual Results:  
Always 2 buttons with one sometime disable, so unusable.

Expected Results:  
1 button with changing appearance like with Stop-or-Reload Button addon.

As exposed in details, this should be the default config, not an addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 194041
Duplicate of bug: 343396
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.