No autocomplete for lower-level domain address

VERIFIED DUPLICATE of bug 407888

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 407888
11 years ago
10 years ago

People

(Reporter: partyzkaft, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

There is no autocomplete a/o highlight when you try to enter lower-level part of domain e.g. 'SOMETHING.domainname.com' when you are already at 'www.domainname.com'.

First imagine you're at https://www.somewhere.domainname.com, then delete in the bar 'somewhere.' and press enter. 

Point at location bar.

If you try to type 'some[...]' you need to put in whole 'something' string then it completes to the rest of 'somewhere.domainname.com'.

I don't think it is eventually possible at all but this trick should make bar a bit more userfriendly :) 

AT LEAST ONLY HIGHLIGHT w/ dropdown would be usefull b/c ofcourse not only one subdomain is on every domain.

Reproducible: Always

Steps to Reproduce:
1. Enter address e.g. bugzilla.mozilla.org
2. Point at loc.bar, delete the word 'bugzilla', press enter.
3. Point again, click before 'mozilla.org' and try to enter word 'bugzilla' - you see? Not completed or even highlighted :)
Actual Results:  
No highlight, no dropdown list w/ history

Expected Results:  
FF would search in history dbase for expected results (match the address user wanted to enter w/ addresses in history w/ subdomains also)

I found it a minute after installing FF 3.0 b2 and reading about new feats of location bar. I noticed the pretty highlight when typing address in and tried to help myself searching for domain resources :) but when I'm into domainname.com I can't highlight my fav subdomains at domainname.com.


Also this is not a bug in its definition, just a cosmetic case w/ enhancement feature.
I think you're referring to bug 407888; sound the same?  Similar?
(Reporter)

Comment 2

11 years ago
Only similiar (but that bug referred by You is also very annoying sometimes). I mean, that if drop-down works fine - so you entered 'bugzilla.mozilla.org' (let's say you entered 'b', the drop-down appeared, you choosed 'bugzilla.mozilla.org'). Now you want to go to 'mozilla.org' so you deleted 'bugzilla'. Now you want to go back to 'bugzilla', so you point at loc.bar before 'mozilla.org' and start typing 'bugzilla' - you won't see any assist in typing (drop-down and/or completing)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407888
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.