Closed Bug 410972 Opened 12 years ago Closed 10 years ago

Animate tab reorganization in tab bar

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 455694
Future

People

(Reporter: NicolasWeb, Unassigned)

References

Details

(Whiteboard: [parity-safari] [parity-chrome])

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

1.Replace the tab position indicator by animating the displacement of the dragged tab
2.Extract a tab from a window by dragging it and show a transparent thumb of the future window
3.Move a tab from one window to an other and give the focus to the destination window during drag & drop and after



Reproducible: Always

Steps to Reproduce:
1.Drag & drop a tab in the tab bar
2.Drag & drop a tab out the tab bar & in the browser content space
3.Drag & drop a tab from one window tab bar to a second window tab bar hidden by the first window (2sd tab bar under 1st window)
Actual Results:  
1.Step 1
 - show the tab position indicator where to insert the tab
 - show the tab at its actual position
 - show the transparent dragged tab under the mouse cursor
2.Step 2
 - load the tab dragged in browser content space, like an external source = reload tab
 - show the tab at its actual position
 - show the transparent dragged tab under the mouse cursor
3.Step 3
 - Can't do if destination tab bar is hidden by 1st window, else :
 - copy the tab URL in a new tab in the destination window : lost content added by user
 - Keep focus to the initial window and to the last active tab in the destination window
 - show the tab position indicator where to insert the tab
 - show the tab at its actual position
 - show the transparent dragged tab under the mouse cursor


Expected Results:  
1.Make
 - tabs sliding in the tab bar & insert a blank area where the tab will be inserted
 - appear only one occur of the tab under the mouse cursor without transparency
2.Make
 - tabs sliding in the tab bar
 - appear only one occur of the tab by showing a transparent thumb of the future window with content under the mouse cursor
3.Make
 - tabs sliding in the tabs bars & insert a blank area where the tab will be inserted
 - appear only one occur of the tab under the mouse cursor without transparency
 - during drag & drop give the focus to the window under the mouse cursor. Keep the focus in the window where the tab is inserted

Now that we have Cario under the hood this should be possible. It's smoother than the solution we use now. I tough it's better for end users it's less technical (insert this tab here, that is not really what we do. We want to say in the screen "*move* this tab here") and more practical. With this functionality you can figure the final result. It's more real human behavior. If you want the tab to move, so make it move...
Comment on attachment 295553 [details]
Extract tab to create a new window Safari behavior

description obsolete
Attachment #295553 - Attachment is obsolete: true
Being able to tear off tabs is bug 225680 and is probably a lot harder than animating tab reorganization.  So I'm restricting this bug report to just cover animating tab reorganization.  (In general, please try to keep bug reports restricted to a single issue.)
Summary: Animate tab reorganization in tab bar AND Change drag & drop behavior in browser window content, like in safari → Animate tab reorganization in tab bar
Whiteboard: p-safari
Duplicate of this bug: 409563
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3+
Target Milestone: --- → Future
Flags: blocking-firefox3.1?
Not blocking, but I do really want this. cc'ing Mano and Dao as I know they've both expressed interest/ideas here as well.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Whiteboard: p-safari → parity-safari
Now with chrome having this, adding it to the parity list.
Flags: wanted-firefox3.6?
Flags: wanted-firefox3.5?
Whiteboard: parity-safari → [parity-safari] [parity-chrome]
Version: unspecified → Trunk
duping to a newer, but slightly more popular and shorter bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455694
Flags: wanted-firefox3.6?
Flags: wanted-firefox3.5?
You need to log in before you can comment on or make changes to this bug.