bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Use Profile Guided Optimization on SpiderMonkey (all platforms)

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Robert Sayre, Unassigned)

Tracking

({perf})

Trunk
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.1 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
I've been able to get substantial improvements with this technique using GCC. See bug 361343 for Windows data.
(Reporter)

Comment 1

11 years ago
Created attachment 295585 [details]
PGO data for Linux and Mac

This data shows improvements in almost all benchmarks. The exception is regex on Linux (very slight regression) and two benchmarks on Mac. I checked the Mac ones in Shark, and they both spend more than 50% of their time under JS_[Get/Set/Find]Property. That tells me these numbers are going to change substantially if we improve property access, so I'll block on a few of those bugs.
(Reporter)

Comment 2

11 years ago
Comment on attachment 295585 [details]
PGO data for Linux and Mac

The Mac uses different settings than Linux because -fvpt profiling proved buggy on Darwin's gcc.
(Reporter)

Updated

11 years ago
Depends on: 365851
(Reporter)

Updated

11 years ago
Depends on: 322889

Updated

11 years ago
Keywords: perf
Version: unspecified → Trunk

Updated

10 years ago
Flags: wanted1.9.1?
The blocking bugs are fixed.  I assume we'll give this a shot after 1.9.1?
(Assignee)

Updated

4 years ago
Assignee: general → nobody
This has been done long ago. I can't find the actual bug for it, but eg bug 467271 talks about some followup fixes.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.