Closed Bug 411105 Opened 15 years ago Closed 15 years ago

Weave seems not to work no more with firefox-3.0b3pre

Categories

(Cloud Services :: General, defect)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dominique.gonzalez, Assigned: hello)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b3pre) Gecko/2008010604 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b3pre) Gecko/2008010604 Minefield/3.0b3pre

I use firefox-3.0b3pre (ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk-l10n/) with weave.0.1.13.
I cannot get the weave dialog box, no log, no log in.

I removed it and reinstalled it.
Still not work.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I know that firefox-3.0b3pre is a pre-release of beta, so i can't expect perfection on it.

But it seemed important to warn about this.
Confirming, seems like a problem importing js scripts:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///Users/dave/Library/Application%20Support/Firefox/Profiles/Minefield/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/weave.js :: <TOP_LEVEL> :: line 44"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://weave/content/load-weave.js :: <TOP_LEVEL> :: line 16"  data: no]

Error: Log4Moz is not defined
Source File: chrome://weave/content/sync.js
Line: 106
Status: UNCONFIRMED → NEW
Ever confirmed: true
Noticed this on Mac too, but it seems to work on Win32 (or maybe my Win32 build is just a bit behind on updates).
OS: Linux → All
Hardware: PC → All
Skimming over the code I'd lay bets on it being related to the changed to the |let| keyword that landed on the weekend.
Severity: normal → blocker
Assignee: nobody → thunder
Taking bug.
Status: NEW → ASSIGNED
Mossop was correct.  I've fixed all the incorrect uses of |let| in Weave, and pushed a new version: 0.1.14.

Closing as FIXED.  To verify, go to Tools -> Add-ons -> Right-click on Weave -> Find update... then restart Firefox.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Part of Weave works, but i cannot actually perform a sync. Also, none of the buttons in the setup wizard seem to work.
Okay, reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
jsquared71:  I did find a 'let' I missed earlier, in the wizard.  I can now go through the wizard w/o problems.  Can you confirm (with 0.1.15)?
Seems to work fine.
I performed a sync between 2 computers without any problem.
The dialog boxes seem to be good.
Great!  Closing as fixed, then :)
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Weave 0.1.15 works for me now. Thanks for the fix.
broken on win32 2008012104 3.0b3pre (weave 0.1.15)
specifically: cannot login, either through the weave options, or by 'verifying' during initial setup (step ?3?) - clicking button once does nothing; clicking it twice closes the window with no ensuing effect (still not logged in).
I'm seeing this as well with nightlies from the past few days. Seems to work OK on Mac, though?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I can reproduce this now on both winxp and mac.  It seems weave is causing the login manager to fail:

Error: uncaught exception: [Exception... "'[JavaScript Error: "l.usernameField is null" {file: "file:///Users/thunder/Desktop/Minefield.app/Contents/MacOS/components/storage-Legacy.js" line: 484}]' when calling method: [nsILoginManagerStorage::addLogin]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Users/thunder/Desktop/Minefield.app/Contents/MacOS/components/nsLoginManager.js :: anonymous :: line 364"  data: yes]
Status: REOPENED → ASSIGNED
FWIW, this is a completely different bug from the one in comments 1-11.
The problem is that nsILoginInfo no longer accepts null as valid parameters for usernameField/passwordField:

  let login = new nsLoginInfo('chrome://sync', null, realm,
                              username, password, null, null);

(the last two parameters)

Changing them to "" (empty strings) makes things work again.  Patch coming up.

Justin, not sure if that is by design or not.  You may want to allow null for those.
by "patch" I meant "weave release" ;)

version 0.1.16 is now out, please update the extension and test if it works! (reopen bug if not).
Status: ASSIGNED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Working now, thanks, Dan!
Blocks: 413314
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.