del key does not remove files from the download manager anymore

VERIFIED FIXED in mozilla1.9beta3

Status

()

VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Peter6, Assigned: elmar.ludwig)

Tracking

({regression})

Trunk
mozilla1.9beta3
regression
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2008010708 Minefield/3.0b3pre ID:2008010708

repro:
open FF
open DM
select a file and hit the [del] key on your keyboard

result:
nada

expected:
the file to be removed from the list

nothing in the errorconsole

this regressed today
(Reporter)

Updated

11 years ago
Summary: del key does not remove files form download manager anymore → del key does not remove files from the download manager anymore
Nor on Mac, neither -> OS: All
OS: Windows 2000 → All
Hardware: PC → All

Updated

11 years ago
Blocks: 392293

Updated

11 years ago
Assignee: nobody → comrade693+bmo
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3 M11

Updated

11 years ago
Whiteboard: [needs patch]
(Assignee)

Comment 3

11 years ago
Created attachment 295831 [details] [diff] [review]
patch v1

Like so? This patch fixes the problem for me.
Attachment #295831 - Flags: review?(comrade693+bmo)
(Assignee)

Updated

11 years ago
Whiteboard: [needs patch] → [has patch]
Oh hey, I missed two.  I regret to inform you that we'll need a browser test for this as well though.
(Assignee)

Comment 5

11 years ago
Well, the bug isn't assigned to me, is it... ;-)

What kind of test do you mean? Litmus?
no - an automated browser test - Like I have in attachment 295657 [details] [diff] [review].
Comment on attachment 295831 [details] [diff] [review]
patch v1

r=sdwilsh

Test being attached momentarily
Attachment #295831 - Flags: review?(comrade693+bmo)
Attachment #295831 - Flags: review+
Attachment #295831 - Flags: approval1.9?

Updated

11 years ago
Attachment #295831 - Flags: approval1.9?
Created attachment 296171 [details] [diff] [review]
patch with test

same patch as v1, but with the test
Attachment #295831 - Attachment is obsolete: true
Attachment #296171 - Flags: review+
Attachment #296171 - Flags: approval1.9?

Updated

11 years ago
Whiteboard: [has patch] → [has patch][has review][needs approval]

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Whiteboard: [has patch][has review][needs approval] → [has patch][has review][can land]

Updated

11 years ago
Attachment #296171 - Flags: approval1.9? → approval1.9+

Updated

11 years ago
Assignee: comrade693+bmo → elmar.ludwig
Thanks for the patch!

Checking in toolkit/mozapps/downloads/content/downloads.xul;
new revision: 1.44; previous revision: 1.43

Checking in toolkit/mozapps/downloads/tests/browser/Makefile.in;
new revision: 1.4; previous revision: 1.3
Checking in toolkit/mozapps/downloads/tests/browser/browser_bug_411172.js;
initial revision: 1.1

Stephen - you can now remove the litmus test for this since we have an automated one for it!
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite+
Flags: in-litmus?
Resolution: --- → FIXED
Whiteboard: [has patch][has review][can land]
I backed out the test for this since it was failing on Linux.  I'm guessing that one of the keys isn't working for removing downloads, and I'm not sure why...

Checking in toolkit/mozapps/downloads/tests/browser/Makefile.in;
new revision: 1.5; previous revision: 1.4
Status: RESOLVED → REOPENED
Flags: in-testsuite+ → in-testsuite?
Resolution: FIXED → ---
Created attachment 296335 [details] [diff] [review]
v2 test

As Ryan pointed out on irc last night - only mac uses VK_DOM_BACK_SPACE.  Oops...
Attachment #296335 - Flags: review?(rflint)
(Assignee)

Comment 12

11 years ago
I should have noticed that as well, but I hadn't looked at the test in detail...

Updated

11 years ago
Attachment #296335 - Flags: review?(rflint)
All better :)

Checking in toolkit/mozapps/downloads/tests/browser/Makefile.in;
new revision: 1.6; previous revision: 1.5
Checking in toolkit/mozapps/downloads/tests/browser/browser_bug_411172.js;
new revision: 1.2; previous revision: 1.1
Checking in toolkit/mozapps/downloads/tests/browser/browser_bug_411172_mac.js;
initial revision: 1.1
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
Verified FIXED using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008011104 Minefield/3.0b3pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008011104 Minefield/3.0b3pre

and

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008011105 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED
https://litmus.mozilla.org/show_test.cgi?id=4553

in-litmus+
Flags: in-litmus? → in-litmus+
In addition to automating the delete-and-then-select-the-next-download testcase above, we should have ones for the following:

* when the user is anywhere but the absolute bottom of the DM list, we should keep advancing/selecting downloads until we come to the bottom of the list, at which point we should start moving upwards.
* we should also test--if possible--that starting to delete from the bottom of the DM list moves upwards
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.