Default selection within a selection group is not working in Firefox

RESOLVED DUPLICATE of bug 46845

Status

()

Core
Document Navigation
--
major
RESOLVED DUPLICATE of bug 46845
10 years ago
8 years ago

People

(Reporter: zee corker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

The following URL is an example of code I compiled that demonstrates Firefox's inability to show a default selection within a selection group.  This feature works in IE6 and the latest opera http://webtech.tstc.edu/students/southr/1311project/donate.html



Reproducible: Always

Steps to Reproduce:
1. enter selected="selected" after individual option in selection group
2.
3.
Actual Results:  
Default selection is not highlighted

Expected Results:  
Each option with selected="selected" should be highlighted in the browser.

Problem doesn't occur in IE6 or the latest Opera Browser

Comment 1

8 years ago
Can confirm this on Firefox 3.0.0.8 Ubuntu Linux. 
This only comes out in reloading the page.

How to reproduce:
create test.html with this code:
<select name="test">
<option value="Test 1">Test 1</option>
<option value="Test 2">Test 2</option>
<option value="Test 3">Test 3</option>
</select>

Open in Firefox. The rendered page shows "Test 1"

Now keep the browser open on this page and edit the file to contain this:

<select name="test">
<option value="Test 1">Test 1</option>
<option value="Test 2">Test 2</option>
<option value="Test 3" selected="selected">Test 3</option>
</select>

Hit refresh on browser and see that it still shows "Test 1"

Expected behavior: the browser should show "Test 3"

This does not affect end users, but is very annoying to developers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Menus → Document Navigation
Product: Firefox → Core
QA Contact: menus → docshell
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
You need to log in before you can comment on or make changes to this bug.