Closed Bug 411347 Opened 15 years ago Closed 15 years ago

Reporter should display info about submitted crash reports that have not been processed

Categories

(Socorro :: General, task, P3)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 422581

People

(Reporter: samuel.sidler+old, Unassigned)

References

()

Details

Reported by ted.mielczarek, May 30, 2007

The reporter should be able to at least know that a report has been
submitted and is awaiting processing, instead of just showing a 404.  For
bonus points, we should display the number of reports in queue or some
other useful info, but I'm ok with that being split off into another issue.

--

Comment 1 by sayrer, May 30, 2007

I think this basically comes down to health monitoring for processor nodes. We need
to get periodic status from them on their Queues, so we can detect an overload.

Would we pay a usability penalty if we included a timestamp in the link we return to
the client?

--

Comment 2 by bsmedberg, May 30, 2007

What would the timestamp do?

I do think we should have a custom 404 page for "missing" reports, with a text like

"The report you requested could not be found. It's possible that it hasn't been
processed yet." If possible, it might also say "there are currently X reports in the
processing queue".

--

Comment 3 by ted.mielczarek, May 30, 2007

Will we get screwed by NetScalar caching if we hit a 404?

--

Comment 4 by sayrer, May 30, 2007

NetScalar should be wise to a 404. We can still communicate useful data in a custom 404 page.

The date would help because we can eliminate old reports that should have been
processed by any reasonable measure. Like, cut it off at a week or a month.
This is easy enough UI that it'd be good to get in. What bsmedberg said in comment 2 above would be good enough.

"The report you requested could not be found. It's possible that it hasn't been
processed yet."

For the reports in queue number, see also bug 411454.
Priority: -- → P3
Assignee: sayrer → nobody
See bug 422581 comment #8.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.