Last Comment Bug 411760 - MinimizeToTray addon not available/working for Firefox 3
: MinimizeToTray addon not available/working for Firefox 3
Status: RESOLVED FIXED
eta:?
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: Trunk
: All All
-- normal with 3 votes (vote)
: Firefox 3
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 325353
Blocks: 364745
  Show dependency treegraph
 
Reported: 2008-01-10 14:46 PST by Alex Polvi
Modified: 2009-10-05 02:15 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Alex Polvi 2008-01-10 14:46:13 PST
https://addons.mozilla.org/firefox/2110/
Comment 1 User image chris hofmann 2008-01-30 15:31:06 PST
checking in e-mail with mook and brad about eta.  it would be great to get this soon.  
Comment 2 User image :Mook 2008-01-30 20:52:13 PST
Summary: ETA: N/A

Err, heh, I actually read bugmail more than I do minimizetotray mail ;)

See the dependency list - I haven't had much time to poke the extension, and since there's plans for actually getting the hard part in the tree, using that is much more preferred.  Sadly it looks like there won't be time post-b3 to get that.

mfinkle mentioned that it might end up as a NPOB component for prism, though.  If that pans out, porting the minimal UI bits (which nobody cares about, really - it's all the tray part) would work too.

P.S. I'm *pretty* sure it doesn't work on 3.0b2 whatever the comments say.  It doesn't even build, and with the IID revs it should be throwing like crazy :)  That's the sad reality of having binary components in an extension.

(Brad's opinion about all this might differ, of course :) )
Comment 3 User image Alex Polvi 2008-03-04 15:07:35 PST
bug 325353 isn't going to land in toolkit until after Fx3... are you able to create a work around? Or are Fx3 users just not going to be able to minimizetotray?
Comment 4 User image Alex Polvi 2008-04-01 13:10:22 PDT
(In reply to comment #3)
> bug 325353 isn't going to land in toolkit until after Fx3... are you able to
> create a work around? Or are Fx3 users just not going to be able to
> minimizetotray?

Mook, just another prod. You have a super popular add-on so we are hoping it will be available for Fx3! :)

Comment 5 User image Alex Polvi 2008-05-07 13:02:42 PDT
Mook, checking in again. Any possibility of a work around so we can get this working with Firefox 3? 
Comment 6 User image :Mook 2008-05-07 20:50:04 PDT
Umm.. Nope, this extension does evil things with knowledge of Gecko internals.  I've had no time and very little interest to work on this :(

I'm always on IRC if anybody needs help porting, but realistically I just won't be doing the actual work (at least, around the Firefox 3 timeframe).

Previous attempts at getting other people interested didn't seem to have much response - or maybe the code is just too crazy :p
Comment 7 User image Alex Polvi 2008-05-23 13:31:27 PDT
Mook, just tried to catch you on IRC -- no luck.

Anyway -- do you know what the issues are? Is it just a matter that things are not building? I had one user report that they have been successfully using the add-on on trunk for awhile now.
Comment 8 User image :Mook 2008-05-23 20:23:27 PDT
When I last checked, at least one interface has changed IIDs.

Actually testing it though, I just see errors in the JS console relating to minimizing all windows.  Which is odd, since it doesn't even build on trunk anymore...
Comment 9 User image Brian 2008-05-30 06:19:43 PDT
I'm really hoping somebody can get this extension updated - I've been using it for a loooooong time and am really missing it in FF3RC1!!
Comment 10 User image RNicoletto 2009-03-19 03:30:07 PDT
There is a newer addon based on MinimizeToTray compatible with Firefox 3: MinimizeToTray For FF 3 , 3.1b and Thunderbird 2.0 and 3.0b2 1.2.2 (https://addons.mozilla.org/firefox/addon/10488).
Comment 11 User image arjktm 2009-09-30 20:42:39 PDT
Its OK guys. Don't worry about minimizing to tray. Use Tray It. You can minimize any windows by holding Shift key while minimizing. 
Download Tray It. 
Add TrayIt!.exe file to startup.
Comment 12 User image arjktm 2009-09-30 21:08:54 PDT
Here is Tray It! Download link
http://www.teamcti.com/trayit/trayit.htm
Comment 13 User image RNicoletto 2009-10-05 02:15:59 PDT
There are at least 2 extensions on AMO that update the original MinimizeToTray:
- MinimizeToTray For FF 3.5 (https://addons.mozilla.org/firefox/addon/10488)
- MinimizeToTray revived (https://addons.mozilla.org/firefox/addon/12581)

Plus, there's an unofficial updated version of the original MinimizeToTray here ==> http://myminimizetotray.googlepages.com/

So for me is FIXED.

Note You need to log in before you can comment on or make changes to this bug.