Closed Bug 411833 Opened 12 years ago Closed 10 years ago

Crash in JS_IsSystemObject when deleting messages in GMail

Categories

(Core :: General, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008011004 Minefield/3.0b3pre.

STR:
I checked two boxes in my Gmail account to delete messages, and then I crashed. Here is the Breakpad URL: http://crash-stats.mozilla.com/report/index/a2b91fe3-bfe8-11dc-bd6e-001a4bd43ed6?date=2008-01-11-01.

I could only find one other bug on file with that stack and it had something to do with Venkman (Bug 402379). Filing this because i haven't seen any crash like this. Wasn't able to reproduce it.
Just loading gmail on a linux trunk debug build gives me:

Assertion failure: !rt->gcRunning, at /work/mozilla/builds/1.9.0/mozilla/js/src/jsgc.c:1336

But it is not reproducible. My first guess is bug 411531 which behaved similarly.
A quick review of Breakpad data shows this is currently the #15 top crash. The graph shows a spike starting right around the 10th of January.
not in top 100 of 3.5b4, 3.0.9, 3.0.10. but do exist in low numbers

0 on crash-stats in 3.6a1pre in last 4 weeks
Severity: normal → critical
Marking WFM because:
* Gmail is very complicated and therefore unlikely to lead to a fix or testcase when the bug is difficult to reproduce.
* It was a topcrash, but now it's not, so it's likely the exact bug Marcia hit is gone.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.