"New Event" fails - requires Thunderbird restart

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Sam, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

Cannot identify sequence to cause "New Event" to fail.  Have been using since Oct2007.  Failure started Dec2007.
I typically manually create one event daily for time tracking (only one event not multiple).  If Thunderbird has been open for over a couple of hours, the New Event  typically fails.  Upon Thunderbird restart, New Event works as expected until next failure.  Failure = click on "New Event" (right mouse menu or standard icon in menu bar) nothing happens.  No messages, no crash - just no action.  All other actions viable in Lightning and Thunderbird.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.


Expected Results:  
New Event - should open New Event window
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008010904) Thunderbird/2.0.0.9 ID:2007103104

Works for me. TB is opened for some days, no problems there.

Comment 2

11 years ago
What kind of calendar? Isn't the calendar set to be read-only? Looks like behaviour losing connection -> calendar becomes read-only -> not able to create new events.
Bas, if it is a read only problem, shouldn't there something in the error console? Sam, have you checked the error console for entries?
(Reporter)

Comment 4

11 years ago
If I select view "Errors", I see
[Exception..."Component returned failure code 0x80004005 (NS_ERROR_FAILURE) [nsIstringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame::XstringBundle::getString::line17"data:no]

I see quite a few of these.
I also see QuickFolders is not defined - but no TB issue.  And I am not actively using.

Those are the 2 error types.

I could uninstall QuickFolders.

BTW - is there an easier way to copy the Error text vs old fashion reading/typing?
(Reporter)

Comment 5

11 years ago
Also, I see
Error -- accountManagerDataSource has no properties
chrome://messager/contnet/msgMail3PaneWindowLine.js     Line: 1109

Will try to review Error Console quicker next time failure occurs.
Of course, not failing right now.  Typical Firefox (current upds) [less then 8 tabs] and TB (current upds) usage before and after noted failure. 30% HD free (15gb).  Typical CPU usage - no runaway app.  Not high net traffic when I'm trying to create a new event either - i.e. not highly multi-tasking.  Calendar not public, nor connect to another webmail.

When I restart TB after a failure, I do not change any other app or setting.  Simply, restarting TB corrects the failure.
(Reporter)

Comment 6

11 years ago
attempt to add "New event" in Lightning failing.  Error Console reports: 
calendar has no properties
chrome://calendar/content/calendar-item-editing.js        Line 191

line highlighted in js is:
   if (calendar.readOnly && mode == "new" && calendars.length < 1) {

However, I CAN edit an existing event, update, save it.
Error repeats with additional New Event requests.

Then, if I open an email in TB, Error Console reports the 2 following errors: the email does open as expected.

[Exception..."Component returned failure code 0x80004005 (NS_ERROR_FAILURE)
[nsIstringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)"
location: "JS frame::XstringBundle::getString::line17"data:no]
XStringBundle         Line 17

loadFolderView is not defined
chrome://quickfolders/content/quickfolders.js   Line 311

loadFolderView error repeats with additional email opens.
(In reply to comment #6)
> [Exception..."Component returned failure code 0x80004005 (NS_ERROR_FAILURE)
> [nsIstringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)"
> location: "JS frame::XstringBundle::getString::line17"data:no]
> XStringBundle         Line 17

XStringBundle is not a calendar source file. I suspect one of your other installed extensions has a bug.
(In reply to comment #4)
> BTW - is there an easier way to copy the Error text vs old fashion
> reading/typing?

Right click the message and select Copy.
Sam, could you retest with Lightning 0.8 Release Candidate 1 or newer?

Could you disable all other extension/themes except Lightning and check if the issue still exists? If yes enable the extensions one by one until the issue appears.
Sam, any update on the information and testing requested in the previous comment?
(Reporter)

Comment 11

10 years ago
(In reply to comment #10)
> Sam, any update on the information and testing requested in the previous
> comment?
> 

Hello Stefan,

I have not had time to remove and slowly add each TB extension back in.
However, to spot test and due to need, I did disable 2 TB extensions - Folder Account (which I don't need) and MailBox Alert (reduce noise for a bit).  I've had these disabled for probably 4 - 6 weeks now.  And have NOT seen the New Event failure.  I've had the same amount of TB usage time (8-10 hrs a day), and  creating/updating Lightening events.  No New Event failure.

My next thought to add each of the 2 extension in one at a time and see which actually causes the failure.

I see a couple of XNote uncaught exception error messages in the Error Console, but no crash.

So for me all is good now.  Let me know if you want me to set this bug as "fixed".

Sam
Resolving as worksforme per previous comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.