Closed Bug 411958 Opened 12 years ago Closed 12 years ago

Use tinderboxen to build gdata-provider nightlies

Categories

(Calendar :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Fallen, Assigned: Fallen)

References

Details

(Whiteboard: [gdata-0.4])

Attachments

(3 files)

Thanks to bug 410922, it is now possible to build the gdata provider and upload it as an extension to ftp.mozilla.org.

It is sufficient to let one tinderbox build the gdata provider, it might look strange if only one tinderbox creates this xpi. Depending on how latest-mozilla1.8 is linked, we might want to go ahead an let all tinderboxen build the xpi.
Enable build for gdata. For now I just picked the sunbird linux tinderbox to build gdata. I would land the Makefile and install.rdf on both branches, test the nightly creation on one tinderbox and see if it uploads to the correct location.

The way it is with this patch, I believe it will land in:

ftp://ftp.mozilla.org/pub/calendar/sunbird/nightly/latest-mozilla1.8/xpi

Is this path ok? Setting up a second tinderbox with the same configs might overwrite the same xpi file, so probably only one is needed. The same change could be done on a trunk tinderbox, then it will also be in latest-trunk/xpi.

Thinking about alternatives, I don't think I can land it in pub/calendar/xpi so easily.
Attachment #297403 - Flags: review?(ause)
Comment on attachment 297403 [details] [diff] [review]
Enable building and uploading gdata

>+++ calendar/providers/gdata/install.rdf	16 Jan 2008 20:22:16 -0000
><!-- Thunderbird -->
><em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
><em:minVersion>2.0a1</em:minVersion>
><em:maxVersion>3.0a1</em:maxVersion>

I think the extension should only install in Thunderbird as supported by the required Lightning version to avoid confusion. For example the gdata extension build that requires 0.8pre should only install in Thunderbird 2.0.0.0 to 2.0.0.*.
I didn't think of thunderbird versioning, but I think we are fine (for now). In case we don't check out a mail tree we won't have the version numbers. Also, I believe the gdata provider also runs on thunderbird trunk without problems. The knockout criterium on thunderbird trunk will be that the <em:requires> will require 0.8pre, which will not run on tb trunk.

Is this sufficient, or should I do the following:

>#ifdef MOZILLA_1_8_BRANCH
><em:minVersion>2.0a1</em:minVersion>
><em:maxVersion>2.0.0.*</em:maxVersion>
>#else
><em:minVersion>3.0a1</em:minVersion>
><em:maxVersion>3.0.0.*</em:maxVersion>
>#endif
Duplicate of this bug: 419260
ause, do you mind reviewing this soon, so I can more easily create nightlies?
Comment on attachment 297403 [details] [diff] [review]
Enable building and uploading gdata

activation in all lightning tb looks best to me
Attachment #297403 - Flags: review?(ause) → review+
I want to check this in tomorrow. Daniel, is that ok with you also for SUNBIRD_0_8_BRANCH ?
Flags: wanted-calendar0.8?
Comment on attachment 297403 [details] [diff] [review]
Enable building and uploading gdata

>+DIRS = base \
>+       caldav \
>+       composite \
>+       gdata \
>+       ics \
>+       memory \
>+       storage \
>+       wcap \
Please add $(NULL).
Ok for 0.8.
Flags: wanted-calendar0.8? → wanted-calendar0.8+
Fixed $(NULL). These are the tinderbox configs I'm checking in, for lightning.
Gdata files checked in on HEAD and MOZILLA_1_8_BRANCH and SUNBIRD_0_8_BRANCH.
tinderbox changes win/linux/mac checked in on HEAD and MOZILLA_1_8_BRANCH
tinderbox changes solaris-* checked in on MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [gdata-cvs]
Target Milestone: --- → 0.8
Not working for mac: The tinderbox is looking for the gdata xpi from the lightning-obj/ppc/dist/universal/xpi-stage/ directory, but gdata is in the non-universal directory.
Seems the correct Thunderbird Trunk / 1.8 Branch support mentioned in Comment #2 and Comment #3 is missing from the checkin?
for mac problem see mac mozconfig of lightning tb and calendar/lightning/build/universal.mk
Flags: wanted-calendar0.8+ → wanted-calendar0.8?
Target Milestone: 0.8 → ---
Flags: wanted-calendar0.8?
(In reply to comment #13)
> Seems the correct Thunderbird Trunk / 1.8 Branch support mentioned in Comment
> #2 and Comment #3 is missing from the checkin?
> 

Since I had no reply regarding my question there, I decided to leave it out. Reopening to fix the mac issue, and since I don't really mind, I'll also put in the trunk version change.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Mac fixes - v1 β€” β€” Splinter Review
Untested, but something like this should fix it. ause, it would be great if you could give this patch a test on a working build mac.
Attachment #313156 - Flags: review?(ause)
daniel promised to do the testing.
my universal build has both xpis:

  /Users/dbo/moz18/sbird-uni-opt-Darwin/ppc/dist/universal/xpi-stage:
  total used in directory 2472 available 16459660
  drwxr-xr-x  5 dbo  staff      170 Apr  3 18:22 .
  drwxr-xr-x  4 dbo  staff      136 Apr  3 17:40 ..
  -rw-r--r--  1 dbo  staff    44847 Apr  3 18:22 gdata-provider.xpi
  drwxr-xr-x  9 dbo  staff      306 Apr  3 18:22 lightning
  -rw-r--r--  1 dbo  staff  1219854 Apr  3 18:22 lightning.xpi
Attachment #313156 - Flags: review?(ause) → review+
Whiteboard: [gdata-cvs] → [gdata-0.4]
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.