I have here a combination of CSS and table formating in my HTML which under FireFox is just broken

RESOLVED DUPLICATE of bug 105520

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 105520
10 years ago
10 years ago

People

(Reporter: Andres Rios, Unassigned)

Tracking

({testcase})

2.0 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8 webaroo/1.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8 webaroo/1.2

When I look at this page using Internet Explorer it renders normally and looks good. When I try to look at the page using FireFox it renders the main parts of the page to the left side of the screen, and most of the page looks okay, but then it take from the <table> tag, and starts rendering all that table and its contents to the far right of the last <div> tage. I don't get it, becuase this behaviour is just bizarre for css and tables, and I have seen it before with other pages as well, so this is not a one-of, this happens all the time when you have mixes of <div> and <table> tags. CSS and tables should be able to play together. They do in Internet Explorer, and even Opera. Closed source is winning here guys, and this is just bad news for all of us. Let's get this MONSTER bug licked please!

Reproducible: Always

Steps to Reproduce:
1.Go to any page with <div> tags providing the main structure
2.Have one <table> tag set inside <div> tag
3.Try to render said site in FireFox, and get a pleseant mess
Actual Results:  
Nasty table render alligned to the right of the containg <div>

Expected Results:  
The Table should be contained in the containg <div>, but its not, it is instead alligned to the right side of the containg <div> which is just lame!

FIX! This is a serious render bug affecting any website using CSS that contains a table.
(Reporter)

Updated

10 years ago
Keywords: css-moz, dom1
Version: unspecified → 2.0 Branch

Comment 1

10 years ago
Created attachment 296806 [details]
Testcase

Comment 2

10 years ago
FWIW, you can workaround the bug using CSS clear:left
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: css-moz, dom1 → testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 105520
You need to log in before you can comment on or make changes to this bug.