Crash when closing windows via Command-W

RESOLVED WORKSFORME

Status

Penelope
General
P2
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Brian R, Assigned: Matt Dudziak)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1
Build Identifier: 8.0.0b2

Penelope/Eudora 8.0.0b2 running on Mac OS X 10.5.1

Closing the main window or a message window via Command-W keystroke results in a crash moments after the window is closed.  I have reproduced this problem on two machines.


Reproducible: Always

Steps to Reproduce:
1. Close the main application window or a message window with Command-W
2. Wait a moment
Actual Results:  
Window closes as expected, followed by the entire application crashing (Quit unexpectedly).

Expected Results:  
Window should close but the app should remain running.

Process:         eudora-bin [477]
Path:            /Applications/Eudora Beta 8b2.app/Contents/MacOS/eudora-bin
Identifier:      org.mozilla.thunderbird
Version:         3.0a1pre (3.0a1pre)
Code Type:       X86 (Native)
Parent Process:  launchd [160]

Date/Time:       2008-01-15 15:58:03.529 -0800
OS Version:      Mac OS X 10.5.1 (9B18)
Report Version:  6

Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Crashed Thread:  0

(I'll post the rest of this trace in an attachment)
(Reporter)

Comment 1

10 years ago
Created attachment 297276 [details]
Stack trace
(Assignee)

Comment 2

10 years ago
I am unable to reproduce this. Perhaps it is unique to Intel-based Macs? I'll leave it open for now. If anyone else is able to reproduce this, please let me know.

Thanks, Matt
Severity: critical → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → 0.5
(Reporter)

Comment 3

10 years ago
Issue is still apparent in Eudora 8.0.0b3

Comment 4

10 years ago
Eudora 8.0.0b3 and Mac Leopard.  Command-W continues to crash the application.  Please keep this open and fix.  Happens consistently in 10.5.4 and the latest Eudora beta.

Comment 5

9 years ago
Making any headway on this bug?  Thanks.

Updated

9 years ago
Blocks: 461316

Updated

9 years ago
No longer blocks: 461316
(Assignee)

Comment 6

9 years ago
Is anybody seeing this problem with Eudora 8.0.0b4?
(Reporter)

Comment 7

9 years ago
Just installed 8.0.0b4 and it seems to be fixed!  I am no longer seeing this issue.  Thanks!
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> Just installed 8.0.0b4 and it seems to be fixed!  I am no longer seeing this
> issue.  Thanks!

OK, then I am going to close this as 'Worksforme'. Please re-open if you see the problem again.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

8 years ago
Target Milestone: 0.5 → ---
You need to log in before you can comment on or make changes to this bug.